• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 19.05.21, 21:09
  • Opened by: Elie Naulleau
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #21540 - front office down for no explanaible reason

My shop is in distress for no obvious reason (no shop, module or theme update, no product added in the catalog) : Error 503 Backend fetch failed, guru mediation , etc.
But if I switch to the prestashop classic theme, the shop works again.
The backend works fine.
Last order was yesterday 14h07. Today at noon I noticed the shop was not functional anymore.

I have enabled DEBUG mode but no message was displayed.

Please help !

Comments

Fred 20 May 2021, 11:33

Hi, Elie Naulleau.
Please ask you hosting provider to help.
There is no any errors in the page https://www.happytoseeyou.fr/en/ even with Debug Mode enabled

Elie Naulleau 20 May 2021, 11:35

I will. But are you able to access the page https://www.happytoseeyou.fr/en/ ?
I cannot.I get a Error 503 Backend fetch failed
As soon as I switch the theme, I can access.

Fred 20 May 2021, 11:38

I'm not able to see your page as well.
Do you have access to server error logs to try to find the error what causes the issue?

Elie Naulleau 20 May 2021, 11:42

Yes, there are somme errors in the error log. Here a re the lastest I can get.

[Thu May 20 00:03:10 2021] [error] [client 54.236.1.13] [host www.happytoseeyou.fr] AH01630: client denied by server configuration: /homez.475/happytos/www/img/p/1/7/7/3
[Thu May 20 02:10:20 2021] [error] [client 185.242.10.208] [host www.happytoseeyou.fr] AH01630: client denied by server configuration: /homez.475/happytos/www/vendor/phpunit
[Thu May 20 02:50:31 2021] [error] [client 54.236.1.11] [host www.happytoseeyou.fr] AH01630: client denied by server configuration: /homez.475/happytos/www/img/p/9/9/6
[Thu May 20 03:07:18 2021] [error] [client 40.77.167.44] [host www.happytoseeyou.fr] AH01630: client denied by server configuration: /homez.475/happytos/www/img/p/1/1/9/0
[Thu May 20 04:27:33 2021] [error] [client 54.236.1.13] [host www.happytoseeyou.fr] AH00687: Negotiation: discovered file(s) matching request: /homez.475/happytos/www/images (None could be negotiated).
[Thu May 20 04:56:28 2021] [error] [client 54.236.1.11] [host www.happytoseeyou.fr] AH00687: Negotiation: discovered file(s) matching request: /homez.475/happytos/www/images (None could be negotiated).
[Thu May 20 08:19:16 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10141: FastCGI: comm with server "/homez.475/happytos/www/index.php" aborted: idle timeout (160 sec)
[Thu May 20 08:19:16 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10149: FastCGI: incomplete headers (0 bytes) received from server "/homez.475/happytos/www/index.php"
[Thu May 20 08:20:14 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10141: FastCGI: comm with server "/homez.475/happytos/www/index.php" aborted: idle timeout (160 sec)
[Thu May 20 08:20:14 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10149: FastCGI: incomplete headers (0 bytes) received from server "/homez.475/happytos/www/index.php"
[Thu May 20 08:38:16 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10141: FastCGI: comm with server "/homez.475/happytos/www/index.php" aborted: idle timeout (160 sec)
[Thu May 20 08:38:16 2021] [error] [client 78.227.188.187] [host www.happytoseeyou.fr] AH10149: FastCGI: incomplete headers (0 bytes) received from server "/homez.475/happytos/www/index.php"
[Thu May 20 09:57:24 2021] [error] [client 66.249.66.139] [host www.happytoseeyou.fr] AH01630: client denied by server configuration: /homez.475/happytos/www/img/p/1/2/4/8

And the latest web logs: (could it be that they are too many crawlers crawling ?)

157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:23 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:24 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:24 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:24 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:25 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:25 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:26 +0200] "GET /fr/maison/happy-tasse HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
78.227.188.187 www.happytoseeyou.fr - [20/May/2021:11:38:26 +0200] "POST /admin379sj8pml/index.php/common/notifications?_token=a9rh53mlZm1qSmVWlvQOmKH2FScMcAiNHum5s9FYcHk&rand=1621503504818 HTTP/1.1" 200 5523 "https://www.happytoseeyou.fr/admin379sj8pml/index.php/improve/modules/manage?_token=a9rh53mlZm1qSmVWlvQOmKH2FScMcAiNHum5s9FYcHk" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:26 +0200] "GET /fr/maison/happy-tasse HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:27 +0200] "GET /fr/maison/happy-tasse HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:27 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:27 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:28 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:28 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:29 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.46 www.happytoseeyou.fr - [20/May/2021:11:38:29 +0200] "GET /en/accueil HTTP/1.1" 500 16116 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
114.119.148.160 www.happytoseeyou.fr - [20/May/2021:11:38:33 +0200] "GET /en/dolls-and-toys?q=Couleur-Pink-Or-Roux-Nature&resultsPerPage=48 HTTP/1.1" 404 192433 "-" "Mozilla/5.0 (Linux; Android 7.0;) AppleWebKit/537.36 (KHTML, like Gecko) Mobile Safari/537.36 (compatible; PetalBot;+https://webmaster.petalsearch.com/site/petalbot)"
157.55.39.158 www.happytoseeyou.fr - [20/May/2021:11:39:23 +0200] "GET /themes/alysum/modules/ps_shoppingcart/ps_shoppingcart.js HTTP/1.1" 200 779 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.17 www.happytoseeyou.fr - [20/May/2021:11:39:30 +0200] "GET /modules/pkthemesettings/views/css/presets/alysum.css HTTP/1.1" 200 251 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.17 www.happytoseeyou.fr - [20/May/2021:11:39:30 +0200] "GET /modules/ps_facetedsearch/views/dist/front.js HTTP/1.1" 200 5714 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.23 www.happytoseeyou.fr - [20/May/2021:11:39:35 +0200] "GET /3037-large_default/album-grand-mere-terre-et-ses-enfants.jpg HTTP/1.1" 200 322858 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
157.55.39.23 www.happytoseeyou.fr - [20/May/2021:11:39:36 +0200] "GET /js/jquery/plugins/fancybox/jquery.fancybox.js HTTP/1.1" 200 8634 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"

Elie Naulleau 20 May 2021, 11:44

Paradoxally, traffic is high for a broken site !
Suspecting a piracy attack, I went back 2 days ago in the backups, just before the last order. But it did not changed anything.

Fred 20 May 2021, 11:46

I don't see any useful information there.
If you have an option to restore a backup that would be easiest solution

Elie Naulleau 20 May 2021, 11:56

Yes I did restore DB and file backups from 2 days ago, before the last order. But the site but ti did not fix the front-end.

Fred 20 May 2021, 12:00

Please make sure there are correct permissions for cache folder /www/var/cache
Try CHMOD 755 or even 777

Elie Naulleau 20 May 2021, 19:14

I found the cause. It is caused by the theme : I have disabled the Instagram module and now I have the shop back online in fr and en language !
So apparently pk_instagram is buggy. As soon as I reactive it, the shop crashes.
I remember to have spent quite a lot of time to enable it (facebook api keys, etc). I thing the wise choice is to get rid of it !

Fred 20 May 2021, 19:15

The module "pk_instagram" has been removed from the theme about one year ago

Elie Naulleau 20 May 2021, 19:26

Ah well, I see, the update process should have delete it!

Promokit Instagram
v2.1.0 - par promokit.eu
Display Instagram images from personal account

Fred 20 May 2021, 19:27

You are right.
There are a lot of thing to improve in the theme and prestashop as well. Developers are working every day

Elie Naulleau 21 May 2021, 11:17

Strangely enough I was not told the the instagram module was removed from the theme a couple of ago (ticket #21150 ). Are we talking about the same module ? Promokit Instagram v2.1.0 ?

Fred 21 May 2021, 11:20

Instagram v2.1.0 is a new module, (folder name pkinstagram)
You had an old version (folder name pk_instagram)

Elie Naulleau 21 May 2021, 11:25

I actually disabled this 2.1.0 module to fix my shop, the previous version was already deleted long time ago when Instagram changed its API. I named it pk_instagram by mistake.
So this is the 2.1.0 version that was faulty, this is the one that, once disabled, allowed my shop to resurrect. Facebook/IG may have change something on there side API-wise ? I prefer to keep it disabled.

Fred 21 May 2021, 12:54

We never seen such problems with the new Instagram module before. We will test it out once more