• Priority: High
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 10.06.21, 15:08
  • Opened by: Mietek
  • Closed by: Fred
  • Closed on: 11.06.21, 13:09
  • Reason: Closed
  • Comment: Glad to help!

Ticket #21668 - Many translations missing

Alysum is missing many, many translations.
For instance

  • themes/alysum/translations/pl-PL/ShopThemeCheckout.pl-PL.xlf has 117 lines
  • app/Resources/translations/pl-PL/ShopThemeCheckout.pl-PL.xlf has 740 lines

The same applies to other XLF files.

We can’t translate/improve many phrases, because there are not available in Backoffice > Translations for Alysum theme.
It seems that the only way to translate a good amount of phrases is to edit files in app/Resources/translations/pl-PL/ directly.

Is this a normal situation?

Comments

Fred 10 Jun 2021, 17:21

Yes, the theme is not fully translated. There are a lot of different reasons for that. Currently we are waiting when prestashop will finish Exporting translations system.
https://devdocs.prestashop.com/1.7/modules/creation/module-translation/new-system/

You don't have to edit any files, you can find all translations in the back office.

Mietek 11 Jun 2021, 09:19

The problem isn't that they are not translated.
It's that many phrases are missing in the backoffice's translations.

We have been configuring and translating Alysum on a test domain.
We then exported Alysum translations and copied the XLF files to the production site, into themes/alysum/translations/pl-PL/.
Maybe that trimmed the translations on the production site.

Fred 11 Jun 2021, 10:30

Yes, it's not fully translated into Polish. Here is how Polish translation looks like in our back office https://take.ms/Gc7iY as you can see only ~40 wordings require to be translated.
We will be working to improve that.