• Priority: High
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 21.06.21, 11:58
  • Opened by: Stephen Stanley

Ticket #21774 - Theme not compatible with 1.7.7.4

Hi.

I purchased and downloaded V7 of the theme and am using PS 1.7.7.4.

I do get an error message that the developers of the store have returned saying

This bug is because of one of the theme modules. So, either theme or theme module is not compatible with latest prestashop. Please contact the theme developer for the same.

The error message appears when I simply click Modules > Module manager in the back office menu and Alysum is not even the active theme currently.

Attempted to load class “Cache” from namespace “Promokit\Module\Pkthemesettings\Cache”. Did you forget a “use” statement for e.g. “Sensio\Bundle\FrameworkExtraBundle\Configuration\Cache”, “Doctrine\ORM\Cache”, “Doctrine\ORM\Mapping\Cache”, “Doctrine\Common\Cache\Cache” or “PhpCsFixer\Cache\Cache”?
[Symfony\Component\Debug\Exception\ClassNotFoundException 0]

Comments

Fred 21 Jun 2021, 12:29

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your Back-office and Server through FTP

Stephen Stanley 21 Jun 2021, 13:01

Sorry.

Updated now.

Alysum is not currently activated but you will see the error listed via backoffice modules>module manager etc.I currently have warehouse activated but their elementor shows an error The controller IqitElementorEditor is missing or invalid. I mention this incase the controller is in some way linked to Alysum also - I am not a programmer (Can you tell :P)

It's a shame there's no way to set these themes up before activating them through prestashop.

Thanks for the support

Steve

Fred 21 Jun 2021, 13:21

Unable to connect to your server

Response: 	331 User dev@statuesqueltd.co.uk OK. Password required
Command:	PASS ********
Response: 	530 Login authentication failed
Error:        	Critical error: Could not connect to server
Stephen Stanley 21 Jun 2021, 13:34

Hi Fred.

No idea why it no longer works. The developers used it today already.

I have set up another for you and tested access. all good on this one.

Host: statuesqueltd.co.uk
user: alysum@statuesqueltd.co.uk
PW: t8255432
port 21

Regards

Steve

Fred 21 Jun 2021, 21:33

Now I can connect. Working on a fix...

Stephen Stanley 21 Jun 2021, 21:39

Thanks a lot.

I disabled the debug mode as it causes havoc with payments from customers and creating orders etc. People keep paying their bill multiple times and the orders are not created haha. The Watehouse developers have fixed their elementor issue now so we are just down to alysum issues :D

Thanks for the help

Steve

Fred 21 Jun 2021, 21:41

ok, I see

Fred 21 Jun 2021, 21:56

The issue has been fixed. Please test to confirm the change

Fred 21 Jun 2021, 21:56

Fixed module is "pkheaderitems"

Stephen Stanley 21 Jun 2021, 22:23

Brilliant,

Thank you very much. I will try to test later when the store is quiet.
As a newbie to themes. I presume if I activate Alysum, I can edit the layout and then revert back to warehouse again without any issues and keep doing this until I have set up Alysum fully and tested?

I mean I can keep activating Alysum and warehouse etc back and forth while setting up etc.

Steve

Fred 21 Jun 2021, 22:25

I can't say for sure. We didn't test out these themes installed at the same time