• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 01.07.21, 19:04
  • Opened by: Lynda
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #21854 - Header issue after theme update

Hi Fred !

Since I updated the theme to 7.0.1 version, there is a second menu at th top oof the header. How to remove it ? There isn’t this menu widget on header builder.

Thank you.

Attachments:

Capture d’écran 2021-07-01 a... (1.35 MiB)

Comments

Fred 01 Jul 2021, 21:57

Hi, Lynda.
Try to clear prestashop cache. Please also check it out in another browser or in incognito mote to be sure that is not browser's cache

Lynda 01 Jul 2021, 22:10

I restored from a backup but I can't set Home page builder on Theme settings ! Save button (enregistrer) doesn't work. Please help me to activate my homepage layout builder.

Attachments:

Capture d’écran 2021-07-01 a... (167.3 KiB)
Lynda 02 Jul 2021, 07:24

Product page layout is also not good.

Fred 02 Jul 2021, 10:38

Hi, Lynda.
We have small vacation now.
Could you please wait a week and then I'll help you to update the theme?

Lynda 02 Jul 2021, 10:52

I'm so sorry to bother you on your vacation but I need to find a quick solution to fix this problem. I tried to restore a backup but there is still this problem, I don't understand why !

Fred 02 Jul 2021, 10:53

But I don't see any "second menu" - https://take.ms/jfjRY Everything looks fine on your website

Lynda 02 Jul 2021, 11:31

I solve the header issue by restore the files, but now I have the homepage and product page layout issue.

Lynda 02 Jul 2021, 14:35

Should I also restore the databse?

Fred 02 Jul 2021, 17:30

You don't need to restore database after theme update.
Do you mean the problem is with product page width?

Lynda 02 Jul 2021, 22:48

I think the main problem is I can't activate the home page builder layout because the save button doesn't work. So, my homepage is destroyed.
Here is my homepage before the update (30 June) : https://webcache.googleusercontent.com/search?q=cache:N3-xqBoJsRUJ:https://www.kalyca.fr/fr/+&cd=3&hl=fr&ct=clnk&gl=fr Here is my current homepage : www.kalyca.fr

Attachments:

Capture d’écran 2021-07-02 a... (121 KiB)
Fred 03 Jul 2021, 11:35

Please try now. Theme Settings seem to work

Lynda 03 Jul 2021, 14:39

Thank you, it works !
But why my product page layout (made with page builder editor) doesn't work ?
See screenshots before and after.

Attachments:

before.jpg (126 KiB)
after.png (756.9 KiB)
Capture d’écran 2021-07-03 a... (230 KiB)
Fred 04 Jul 2021, 10:32

Now it should work, please check it out

Lynda 04 Jul 2021, 12:48

Thank you very much !
I will try again the theme update after 10 July. Happy holidays !

Fred 04 Jul 2021, 22:29

Thank you for understanding!

Lynda 13 Jul 2021, 16:27

Hi Fred !

Coud you help me to update the theme, please ?

Fred 13 Jul 2021, 16:57

Hi, Lynda.
That is a major update where we moved from outdated Page Builder to a new, modern Elementor module.
If you really need and going to use this feature, I can try to help you with update. But if you want to keep using Page builder, maybe would be easier to keep using current theme version.

Lynda 19 Jul 2021, 19:02

Is it possible to downgrade to 5.7.1 if I'm not satisfied by version 7.0.1?
If so, please help me to do update.

Fred 19 Jul 2021, 19:10

Hi, Lynda.
I’m sorry, it’s impossible

Lynda 13 Aug 2021, 15:47

After the update, will the design of my site be destroyed?
If so, I will make a copy of my shop to rebuild the design. Will it work or I have to buy a second theme licence?

Fred 15 Aug 2021, 19:18

After the update, will the design of my site be destroyed? - Every customer has it's own configuration what doesn't allow to say for sure
No, you don't need another license

Lynda 17 Aug 2021, 21:52

I installed a copy of my shop in a subdomain. Could you help me to update this copy please? I updated connexion informations in my account (except shop url).

Fred 18 Aug 2021, 10:16

When I try to make an update I get following error message

(error code 28) Operation timed out after 5000 milliseconds with 6384615 out of 11974234 bytes received

That seem a server configuration problem. Here is possible solution for you https://docs.presscustomizr.com/article/326-how-to-fix-a-curl-error-28-connection-timed-out-in-wordpress

Let me know once it will be fixed. You can also try to update the theme yourself through the Theme Settings module

Lynda 18 Aug 2021, 18:17

The automatical updated worked, but I don't see Creative Elements page builder and there is still outdated page builder...

Fred 18 Aug 2021, 20:17

because those modules are not installed.
Go to Modules Catalog, find Creative Elements and install it. Then find Promokit Widgets and install it too

Lynda 18 Aug 2021, 21:21

OK. I disabled Promokit Page builder and created a homepage with Creative Elements but my homepage is blank. Have I selected the good template?

Lynda 18 Aug 2021, 22:18

I fix this problem by changing the hook from displayHome too displayHomeBuilder.

Lynda 18 Aug 2021, 23:07

I'm trying to create a header. I go to Creative Elements → Theme Builder → Add new, and in the field "Type", there is only "Page", and not "Header" (neither Footer, Contact page, Page 404 like the screenshot of a video tutorial). Why ?

Fred 19 Aug 2021, 10:09

I just updated a file of theme settings module here /modules/pkthemesettings but nothing changed in the dev website. Are the FTP credentials correct?

Lynda 19 Aug 2021, 12:29

Sorry, it was the prod website login. I updated FTP credentials. Is it necessary to restore the file you have updated on prod website?

Fred 19 Aug 2021, 13:22

Ok, so the problem was with child theme.
I have renamed following folders to force load original files

/themes/child_alysum/assets
/themes/child_alysum/modules
/themes/child_alysum/templates

I'm afraid I also did that for the production store, please check it out. if you will see the folder name "assets-" (and others) just rename them back to "assets"

Fred 19 Aug 2021, 13:23

Now layouts works fine, you just need to configure them