• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 09.07.21, 07:34
  • Opened by: Nicolas
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #21897 - Label out of stock

Hello,

All seems well configure (new installation), but I have no labels on miniatures and in the catalog.

Comments

Fred 09 Jul 2021, 09:44

Hi, Nicolas.
Could you please give me a link to a page where the labels should appear?

Nicolas 09 Jul 2021, 12:08

Hi Fred,

On the homepage:
https://lefranccurieux.fr/ TRIMERESURUS ALBOLABRIS, SQUELETTE EN ROND (L) is out of stock

And on this page :
https://lefranccurieux.fr/78-mygales-et-araignees Eurypelma spinicrus (ID 1807) is out of stock too.

Same troubles with the AMP version.

Fred 11 Jul 2021, 16:13

Spent much time on that with no success. I assume that's a configuration problem.
Do you have an option to switch the theme to Classic prestashop one and check out labels there?

Nicolas 11 Jul 2021, 16:37

I switch, and same trouble, no "out of stock" labels.
This is just insane as it is a clean and recent installation :/

Attachments:

Classic.jpg (135.6 KiB)
Fred 12 Jul 2021, 12:54

Looks like a bug or a configuration question.
I have tried to find an answer on the internet but with no success yet

Nicolas 12 Jul 2021, 13:33

I fix the problem in the category pages adding a code that was missing in the templates/catalog/_partials/miniatures/product.tpl

{if ($product.quantity == 0)}
<li class="pack">Vendu</li>

(I create a child theme by the way)

The label is ok (example : https://lefranccurieux.fr/97-papillons)
But not on the widgets on the homepage and not for AMP

Fred 12 Jul 2021, 16:44

Ok,
Added following code

{literal}{{#quantity_null}}{/literal}
  <li>{l s='Unavailable' d='Shop.Theme.Amp'}</li>
{literal}{{/quantity_null}}{/literal}

In the file

/themes/alysum/templates/mobile/catalog/_partials/miniatures/product-miniature.tpl
Nicolas 13 Jul 2021, 07:19

Everything works it's perfect, thank you

Fred 13 Jul 2021, 10:16

You are welcome!

Nicolas 16 Jul 2021, 12:41

Ok so
When I check here :
https://lefranccurieux.fr/77-scorpions

The out of stock have no labels and the In stock have a out of stock label

Annoying trouble!

Fred 16 Jul 2021, 12:57

Sorry, but you added that "fix".
You can try to change the "$product.quantity" to "$product.quantity_all_versions" maybe that is a solution

Nicolas 16 Jul 2021, 15:30

Hi Fred,
Sorry wrong URL !

https://lefranccurieux.fr/77-scorpions is ok
https://lefranccurieux.fr/mobile/category/77-scorpions is not, the out of stock have no labels and the In stock have a out of stock labels

Attachments:

AMP.jpg (39 KiB)
desktop.jpg (84.7 KiB)
Fred 16 Jul 2021, 22:34

I need access to your FTP Currently I'm not able to connect

Status:      	Using username "u77508721-assist". 
Status:      	Access denied 
Error:        	Authentication failed.
Error:        	Critical error: Could not connect to server
Nicolas 16 Jul 2021, 22:44

i have updated the password in my profile, connection on ionos is by SFTP

Fred 17 Jul 2021, 10:34

Please check it out now, it should be correct.
Updated file is
/themes/alysum/templates/mobile/catalog/_partials/miniatures/product-miniature.tpl