• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 20.07.21, 21:31
  • Opened by: Daniele Lombardini

Ticket #21975 - Amp

In the Amp version I have several errors:
1. The webmaster console is full of errors which is not normal
2. When you put a product in the cart and open the cart side window if you press the “Cart” button the Cart page loads empty, even if the console shows that the products in the cart are still there, it shows in the result of the ajax call
3. It has happened several times that the product is added to the cart and by opening the side window of the cart after 1 second it disappears from the Cart
4. The products are not added to the cart from modules such as “Isotope”, “Last Viewed”, “From the same category” etc. but the “Add to cart” buttons are present which at this point should not be present, it is possible to deactivate them in AMP?
I have watched your live demos and there are not all these problems.

Attachments:

console_errors.mp4 (733.2 KiB)
it_does_not_show_products_and... (1.24 MiB)
products_disappears_from_cart... (326.3 KiB)

Comments

Fred 21 Jul 2021, 13:11

Hi, Daniele.
AMP code is clear and valid by default. Did you customize AMP files?
Can I upload original AMP files to your prestashop?

Daniele Lombardini 21 Jul 2021, 16:26

Yes, you certainly can upload it but we haven't made any changes to AMP files

Fred 22 Jul 2021, 16:50

The issue has been fixed. Please test to confirm the change