• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 22.07.21, 17:03
  • Opened by: Luca Siesser
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #21996 - urgent problem after update amp checkout

Hi Fred,

I updated to last version.. I’ve two problem.. the more urgent is than on amp, it is loading the desktop version for checkout and not the amp one.. could you say me how to solve.. it’s urgent
The second problem is that know I’ve two logo in the header on desktop version.. kindly see attached

Luca

Attachments:

Schermata 2021-07-22 alle 17.... (577.8 KiB)

Comments

Luca Siesser 22 Jul 2021, 18:42

Hi Fred,

another problem on desktop version is blank product page..

Attachments:

Schermata 2021-07-22 alle 18.... (162.9 KiB)
Luca Siesser 22 Jul 2021, 18:59

Hi Fred,

I disable the simple layout builder so I don't have anymore the duplicated menu and logo..
Could you let me know where I can assign the layout in page builder for the product page and for the home page?

Luca

Fred 23 Jul 2021, 08:14

Hi, Luca Siesser.
The issue has been fixed. Please test to confirm the change

Luca Siesser 23 Jul 2021, 08:28

Hi Fred,

home page and product page are now working.
If you can, there is always the more urgent issue.. on AMP it's loading the desktop checkout version and not the AMP one.. could you let me know how I can fix it?

Best regards,
Luca

Fred 23 Jul 2021, 08:30

I don't see the issue. AMP works fine for me on mobile phone https://take.ms/mEuqdC

Luca Siesser 23 Jul 2021, 08:59

Hi Fred,

the problem is on checkout.. try to add a product to the cart and than go to the checkout.. https://www.dropbox.com/s/q5hsnptmqlb1q4n/Registrazione%20schermo%202021-07-23%20alle%2008.57.40.mov?dl=0

Fred 25 Jul 2021, 08:59

I have updated AMP module but nothing is changed.
There is no such issue in our test server. Did you change Friendly URLs settings?

Luca Siesser 25 Jul 2021, 10:29

Hi Fred,

no.. I didn't change anything..
There is an issue on the AMP home page too.. it's repeated two times.. the new one I've created and that might be now the default one doesn't apply..

Luca

Fred 25 Jul 2021, 14:21

Need more time. We can't figure out what's wrong

Luca Siesser 28 Jul 2021, 17:59

Hi Fred,

ok.. please.. the amp checkout it's the more urgent as it impossible to buy..

Luca

Fred 28 Jul 2021, 20:48

Try to disable Friendly URL's option and enable it back, that will regenerate .htaccess files with redirection rules

Luca Siesser 29 Jul 2021, 14:07

Hi Fred,
I've just tried without any result.. feel free to try you, too
Luca

Fred 29 Jul 2021, 21:17

We spent much time on that with no result.
Do you use some specific checkout module, or another specific module? I need a hint to continue to find out the reason

Luca Siesser 30 Jul 2021, 15:59

no Fred.. I didn't install any module and neither any applied any kind of mods.. the site is always the same with the same modules from more or less when I installed the theme.. I neither updated P to the last version to non risk any problem..

Fred 08 Aug 2021, 10:22

I have enabled "desktop checkout" option here https://take.ms/fxf7T

That's best solution I can offer to you now. We spent much time with no success. Seem the issue caused by server or prestashop configuration

Luca Siesser 18 Aug 2021, 18:54

Hi Fred,

I updated to Prestashop 1.7.7.6, I've always the problem with checkout BUT I've again, too, the the problem with category page, error 500.. is it always necessary to updated manually the file? Could you link it?

Luca

Luca Siesser 18 Aug 2021, 19:06

Hi Fred,

just to resume... after updating to Alysum Version 7.0.1 I've this errors:

1. amp checkout doesn't work as expected.. only if I force desktop version
2. amp category page error 500
3. amp analytics doesn't work anymore

Please, kindly say me how I can solve these

Luca

Fred 19 Aug 2021, 10:21

1. In progress...
2. Category page works fine for me https://take.ms/UJZwI

3. What was changed before analytics stopped working?

Luca Siesser 23 Aug 2021, 17:17

Hi Fred,

1. In progress...
thank you..
2. Category page works fine for me https://take.ms/UJZwI amp subcategory doesn't - https://soundimage.it/mobile/category/28-proiettori-home-cinema Please, take a look to this screen record.. https://www.dropbox.com/s/yb2vznt3woej6vw/Registrazione%20schermo%202021-08-23%20alle%2017.06.42.mov?dl=0 The first time you open a subcat, it loads correctly but it's impossible to click on the menu.. if you reload the same, error 500.. if you go back and you click on another one it loads the first time but then the problem is the same, it's impossible to click on the menu end if you reload, error 500
3. What was changed before analytics stopped working?
I update the theme and Prestashop to 1.7.7
4. always on AMP after update.. I can not change it in the AMP home configuration, the one is set like default doesn't appear.. the one appear don't match the conf you see in AMP home configuration

Luca

Fred 24 Aug 2021, 12:14

2. The problem caused by pspixel module. It's not compatible with AMP
3. Need time to figure out what happened
4. AMP homepage works as I can see https://take.ms/E5Ba6

Luca Siesser 24 Aug 2021, 16:12

1. amp cart.. please, this is urgent..

2. The problem caused by pspixel module. It's not compatible with AMP
Do you mean the FB pixel official module? I've this installed from always and it never created any kind of problem before the last update, the amp site worked perfectly bofere this update

4. AMP home page, no it doesn't work.. fell free to delete it or edit.. if you open the image gallery setting, the form is completely blank.. if you try to modify it, nothing happens... you lost any mod you save and these are not applied

Attachments:

Fred 24 Aug 2021, 17:50

1. You are only one with such problem, that means the problem is definitely with your environment configuration. it's hard to find a reason in such cases. Can't you use it with "desktop checkout"?

Luca Siesser 25 Aug 2021, 13:14

Hi Fred,

let's try to go step by step..

1. home page.. as you can see, the home page is duplicated.. here a short video - https://www.dropbox.com/s/kbw9021ggv7ecm6/Registrazione%20schermo%202021-08-25%20alle%2012.57.48.mov?dl=0

in the BO, I have two different amp home page settings link, the first in Layout Builder and the second in Google amp that looks to point to two different layout profiles.. the first called amp-home, this is the one that appears on top in the home page and that is possible to modify, the second called new amp home that appears immediately after in the amp home page.. if you open any widget for this second one, the forms are empty and, as said yesterday, it doesn't save and neither apply any change.

Is it possible that something gone wrong with the update and I have two amp versions with two configurations that are going in conflict? If you take a look to the home page, the first link to the blog article is translated in Italian and the second one is in English as if they point to different translations..

Fred 27 Aug 2021, 14:45

Yes. In the latest theme version we have removed Page Builder module and added this option right into the AMP module. If you didn't update whole theme use it as previous through Page Builder module.
As for the translation, just make sure everything is translated in your back office

Luca Siesser 30 Aug 2021, 12:38

Hi Fred,

I updated header, homepage and footer with creative, category page and product page are theme default so I can disable and then uninstall Promokit Page Builder?

Luca

Luca Siesser 30 Aug 2021, 12:42

I updated with creative all sub menu, too.

Fred 30 Aug 2021, 13:46

Yes, better to use Creative Elements only and disable/uninstall Page builder

Luca Siesser 30 Aug 2021, 13:46

ok.. I try now..

Luca Siesser 30 Aug 2021, 14:54

Hi,

I uninstall Page Builder and some problems I had, looks to be solved but some other not yet..
Theme Settings, it it normal that in product page theme setting are no more present any option? Please, see attached..
AMP homepage settings.. I don't see anymore two home pages.. but, ad example, in image gallery.. all settings are blank.. if I modify anything it doesn't save..

Could make it sense to uninstall and then reinstall, theme setting module and amp module or could be better to manual update the entire theme?

Luca

Luca Siesser 31 Aug 2021, 14:14

Hi Fred,

just a quick update on AMP.. I disabled Analytics on AMP and I don't have anymore error 500 on category and subcategory so I don't think error 500 was related to my implementation but to Analytics one in the last update..
Regarding the problem I have with the amp cart, it looks to be related to a fetch error on Json data.. error 500

Luca

Fred 31 Aug 2021, 18:41

How to see the issue with cart? it works fine for me https://take.ms/ZvzaU

Luca Siesser 04 Sep 2021, 15:43

HI Fred... sorry for the late answer.. simply go ahead.. normally it stops to work after you press PAY or immediately after the address confirmation as you can see in this short video - https://www.dropbox.com/s/1daif2xq65zmpnu/Registrazione%20schermo%202021-09-04%20alle%2015.38.59.mov?dl=0

I attach, too, some other errors always on amp when it doesn't load the image

Attachments:

Fred 06 Sep 2021, 11:53

Product page image is fixed.
As for the checkout page there is still no success.
We never seen the issue before. You are only one who has such problem what means it depends on specific configuration and make the problem hard to sort out

Luca Siesser 10 Sep 2021, 17:52

Hi Fred,
waiting to find a solution for the AMP cart, I'm trying to modify the mobile version for the header I created with Element.. I followed their video but I cannot find where I can reduce the logo size on mobile version as them suggest to do, is it necessary to buy the complete licence?
Luca

Fred 11 Sep 2021, 10:02

Wait, Elementor and AMP are different things. If you are using AMP you can't build your layout with elementor

Luca Siesser 11 Sep 2021, 10:04

yes.. I'm just trying to have an header AMP like as I have to use desktop checkout on mobile

Fred 11 Sep 2021, 10:09

I just enabled Simple Header option https://take.ms/Oelre to let you have the same header as in AMP

Luca Siesser 11 Sep 2021, 10:16

Fred,

thank you.. now it's looks a lot better but on desktop, the header is duplicated now.. see attached

Attachments:

Fred 11 Sep 2021, 10:32

Fixed. That was a cache issue

Luca Siesser 11 Sep 2021, 10:34

ok.. thank you.. I see it's available the theme update, can I try to update??
last question, can I activate again opcache?

Fred 11 Sep 2021, 10:35

Of course it's available in the update. Yes, you can enable Opcache now

Luca Siesser 11 Sep 2021, 16:00

Hi Fred, updated!
I've just rebuilt contact page with CE but the contact from doesn't send the message, could you check?
One other question, is it possible to rebuild the CMS pages with CE? If I try i receive an error.. this position is not supported by your theme

Luca

Fred 13 Sep 2021, 11:45

Both issues are fixed

Luca Siesser 13 Sep 2021, 11:46

thank you very much Fred!

Fred 13 Sep 2021, 11:46

You are welcome!