• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 27.07.21, 15:12
  • Opened by: Maham Mehrabi

Ticket #22015 - Site broken after any update

Hi, when I try to update something on the website, in the front-end, it broke and I have to upload a previous backup.
For example, I was trying to change some css custom code, and when i’ve updated a parameter (padding: 10px 1px 1px 1px) and saved the css the homepage disappered.
It happend few time, with revolution slider too.
Is there any solution to this? Because become impossible to work in this way.
Thanks.

Comments

Fred 28 Jul 2021, 08:08

Hi, Maham Mehrabi.
Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your Back-office and FTP Server

Maham Mehrabi 28 Jul 2021, 09:55

Hi, Fred.
I've added all the requested info, please check it out, hope we will find the solution to this. Thanks.

Fred 28 Jul 2021, 10:28

I just added custom CSS code with no problem and home page works fine. See the screenshot https://take.ms/uYdg9

Maham Mehrabi 28 Jul 2021, 10:51

Yes sure cause we restored e previously back-up, check the theme version.
With the update does not work.

Fred 28 Jul 2021, 10:52

Ok, but how to see the problem?

Maham Mehrabi 28 Jul 2021, 10:56

I've updated the theme so you can check on these. I have not touched anything, so please try to modify something: css, slider or whatever else on the front-end (we have a full backup of the account), and you will see the site will broke, and even the secondary pages (like product details, or everything else).
Thanks.

Attachments:

before.png (39.6 KiB)
after.png (39.2 KiB)
Fred 28 Jul 2021, 11:02

Yes, I see now.
We have added new Elementor module instead of old Page Builder and recommend to use the new module and disable old one due because of better performance.

But if you want you can keep using old module and I'll fix the problem with disappeared layout

Maham Mehrabi 28 Jul 2021, 11:06

Do I have to download the elementor module to work with it? Or it comes with the update? There is no problem to work with that.
So the procedure is: enable elementor (that I cannot find on the modules), disable the page builder, and keep working correctly, right?
Thanks for the support

Fred 28 Jul 2021, 11:07

If you don't see it, go to Modules Catalog and install Creative Elements module. Then install our widgets module "Promokit Widgets"

Maham Mehrabi 28 Jul 2021, 11:28

This module costs 79,99€, we have already bought the theme, do we have to pay for the builder too?

Fred 28 Jul 2021, 11:31

No, that module is provided with the theme for free

Fred 28 Jul 2021, 11:32

I don't have access to your back office

C'è un errore.
Account dipendente inesistente, o password errata.
Maham Mehrabi 28 Jul 2021, 11:33

wait we restored the account, I create it again, wait 10 minutes then try again please.

Maham Mehrabi 28 Jul 2021, 11:51

Ok I see the elementor builder, it works correctly, the old home page doesn't load with all the functions, but we will fix it, thanks for the support!

Fred 28 Jul 2021, 12:47

Ok, let me know if you will need further assistance

Maham Mehrabi 28 Jul 2021, 15:49

I don't know why every template that I load the homepage appeare pretty empty, it doesn't catch, for example, the products, where they are inside the db.
The electronics template doesn't work properly, I've remove it and imported it again, but it not appear... Can you help me with that?
Any slider doesn't load any image, and i see the loading icon rolling non-stop..
Thanks

Maham Mehrabi 29 Jul 2021, 14:13

Can you help me with that please?

Fred 29 Jul 2021, 21:03

I'm not able to connect to your FTP server

Status:      	Resolving address of ftp.farmasempre.it
Status:      	Connection attempt failed with "EAI_NONAME - Neither nodename nor servname provided, or not known".
Error:        	Could not connect to server

Please update credentials in your profile https://support.promokit.eu/index.php?do=myprofile to access to your FTP Server

Maham Mehrabi 30 Jul 2021, 09:46

I've re-added the ftp account, you can check it out. thanks.

Fred 01 Aug 2021, 12:04

Sorry, but I'm not able to connect via FTP https://take.ms/EV3gJ

Maham Mehrabi 02 Aug 2021, 09:06

Hi,
sorry the FTP hostname is "farmasempre.it", without FTP.
I have updated the info.

Fred 02 Aug 2021, 13:32

For some reason you didn't have Electronics templates. I just imported layouts for you, please check it out

Maham Mehrabi 02 Aug 2021, 15:08

Thanks,
I'll try and let you know.

Fred 02 Aug 2021, 16:56

Ok