• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 31.07.21, 10:21
  • Opened by: ROYNS
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #22037 - Problems with AMP

problem 1= in the User Area I can’t scroll down to see all the menu, as you can see in the screenshot. and I told you before in my other ticket that the scroll in the USER AREA is lagging and totally not stable, random problems like sometimes I cant scroll up

Problem 2= I was testing the website on different phones I found that when I open the website on a new phone, then the AMP is not loaded and the normal website version is loaded instead, however, the AMP version load randomly after I click on the “add to cart” button or click on random menu button.

Attachments:

problem 1 cant scroll down.png (40.5 KiB)

Comments

Fred 01 Aug 2021, 21:17

Did you edit AMP source files? We have tested out our demo and there is no such problem. See the screenshot https://take.ms/OJlGv

ROYNS 01 Aug 2021, 21:36

I have not edited anything, that "helpdeskdialog" is related to the chat module. which shows a button on the user area

ROYNS 01 Aug 2021, 21:38

i just disabled the module and the problem was gone, but that not a solution because the button has to be there

Fred 01 Aug 2021, 21:46

The issue should be fixed
Updated file is /public_html/themes/alysum/templates/mobile/customer/myaccount-links.tpl
Try to enable that module now

ROYNS 01 Aug 2021, 22:54

i just disabled the module and the problem was gone, but that not a solution because the button has to be there

ROYNS 01 Aug 2021, 23:11

the problem is still there, unfortunately!

Fred 02 Aug 2021, 07:10

Sorry, my bad. Now it works

ROYNS 02 Aug 2021, 07:43

the problem is still there, unfortunately!

ROYNS 02 Aug 2021, 07:44

sorry it somehow keeps resending my last comment

Fred 02 Aug 2021, 12:47

No problem. Is the issue solved now?

ROYNS 02 Aug 2021, 12:55

The scrolling problem is solved but the other modules in the User Area have disappeared, they were there yesterday, please restore them as they were yesterday.
i have attached a screenshot of the module which they were hooked there yesterday

Attachments:

Fred 02 Aug 2021, 12:57

I have removed the hook what allowed other module to appear there. But the code those module used is not compatible with AMP. That make the website invalid and causes problems like you have reported initially.


Any third party module is not compatible with AMP by default. We have "AMPified" all prestashop pages and our own modules for the theme but we are not able to "AMPify" every third party module.

ROYNS 02 Aug 2021, 13:04

I understand but yesterday the only hook that was causing the problem was that "helpdeskdialog" from the Live Chat Module, can we just give up the Live chat module and keep the rest? yesterday the other modules were shown there with no problem even they did not show icons but that was enough for me.
can please just delete the live chat hook but keep the others?

Fred 02 Aug 2021, 13:06

if you want I'll get back that hook for you.
Then you will need to go to Design → Positions, find there your modules and remove these from that hook

ROYNS 02 Aug 2021, 13:15

ok put back the hook for the marketplace module and the affiliate/reward model. yesterday the modules (marketplace, affiliate) just showed as links in the menu, but that was ok for me.

"Then you will need to go to Design → Positions, find there your modules and remove these from that hook"
this will delete the hook in the AMP version only right?

-is your module "Promokit Favorites" also a problem?? because I see that it also gone from the AMP User Area

Fred 02 Aug 2021, 20:55

Ok, I just returned that hook.
As for the "Promokit Favorites", it should works correctly for AMP