• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 27.08.21, 19:35
  • Opened by: Lynda

Ticket #22192 - Theme Settings 2020 doesn't work

Hi Fred,

Theme Settings 2020 doesn’t work. See the screenshot on debug mode. It seems it’s since Prestashop update.
Also, on debug mode, there is a “Prestashop database error on front office”.

Thank you for your help.

Comments

Lynda 27 Aug 2021, 22:10

Thank you, Theme Settings works now. But why are there no more settings on Home page and Product Page tab?

Attachments:

Fred 28 Aug 2021, 16:45

because we have changed the logic of page layouts. Everything works well with creative elements module

Lynda 28 Aug 2021, 18:31

What about "PrestaShop Database Exception" error? It means the table ps_ce_template is a Creative Element table, but my production site has Alysum 5.7.1, so not Creative Element module...
The change of logic of page layout you are talking about was on my development shop (ticket #22140), but maybe we made this change by mistake on my production site, which would probably explain this error. What do you think?

Fred 30 Aug 2021, 11:47

Where I can see the "PrestaShop Database Exception" error?

Lynda 30 Aug 2021, 14:15

Enable debug mode and go to my homepage. Please disable debug mode after the test.
I think this error is related to your fix of ticket 22140. What file have you modified please ?

Fred 30 Aug 2021, 17:58

The issue has been fixed. Please test to confirm the change

Lynda 03 Sep 2021, 10:23

I confirm. Thank you Fred.

Fred 03 Sep 2021, 10:25

You are welcome!