• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 23.09.21, 18:16
  • Opened by: Kurt
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #22319 - How install Docker variant on Plesk?

Hey :)

I have a server and I am managing it over Plesk.
I have several domains running on it, but i am not totally sure how to start.
I have put the docker .zip file (litespped.zip) in to the root of the domains which is the following folder.
var/www/vhosts/domain.com/httpdocs

And then i would run ./setpermissions.sh and ./install.sh over ssh but I wasn’t brave enough because i fear that it might brake or interfier with my plesk setup?
Or is that the right way to go? Or should I only use the Docker addon of Plesk?

Comments

Fred 23 Sep 2021, 22:15

Hi, Kurt Kip.
We are not able to give you an answer. Please apply to your hosting support with this question

Kurt 24 Sep 2021, 02:19

I have a V-Server, and they are giving no real support.

How would you approach that for example on a setup with cpanel, with multiple domains?
I guess it is managed relatively like a bit in a same way.

I could give you also access, I have 2 V-Servers and there are more for testing none of them are in live use, so it doesn't matter if we mess something up.

Fred 24 Sep 2021, 10:35

We really can't give you any reply. Only hosting support can explain that to you. We have no information how your hosting is working

Kurt 24 Sep 2021, 16:30

They sadly have no hosting support.

You have never installed the docker version on a Cpanel managed server?

Kurt 24 Sep 2021, 17:07

If not, it is not a problem.

Then I will try to contact Plesk Support, since my hoster is giving no technical support.
But could you maybe give me a hint to what I may ask more specific to your docker image?

Fred 24 Sep 2021, 17:40

We recommend to use prestashop in docker on vps but if you have Plesk maybe would be easier to install Prestashop in "usual" way

Kurt 26 Sep 2021, 18:48

If not, it is not a problem.

Then I will try to contact Plesk Support, since my hoster is giving no technical support.
But could you maybe give me a hint to what I may ask more specific to your docker image?

Fred 26 Sep 2021, 21:23

There are no any special requirements for docker image