• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 24.09.21, 11:27
  • Opened by: Stefano Paolucci
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #22323 - Product variations on Mobile doesn't working | AMP

Hello,
product variations don’t work well when it should be just a single variation.
In the desktop version when I select “Nessuno” works well (see first image attached) but in mobile when I select “Nessuno” they combine with other options. Is a prestashop bug or a theme problem?

Other questions, how can i put custom js and css for mobile?

Attachments:

Cattura.JPG (292.9 KiB)

Comments

Fred 25 Sep 2021, 11:06

Hi, Stefano.
Could you please give me a link to a page where I can see the issue?

Stefano Paolucci 26 Sep 2021, 17:46

Mobile Version: https://bit.ly/3CKkgfO (visible only on mobile, it'll loads desktop version if screen size is big)
Desktop Version: https://bit.ly/39BFpwc

Fred 28 Sep 2021, 09:24

The issue has been fixed. Please test to confirm the change

Stefano Paolucci 28 Sep 2021, 10:07

Hi Fred,
now I have several problems on my product page.
Title disappeared, both description aren't visible, name of product page isn't the metatitle I set.
Mobile doesn't work, I can't choose and product with only "Nessuno", it gives me other options.

Attachments:

Fred 28 Sep 2021, 10:36

I need to update whole AMP module, and I need access to your FTP

Stefano Paolucci 28 Sep 2021, 13:23

Updated it

Fred 29 Sep 2021, 11:14

Please disable Opcache for a while in your server configuration

Stefano Paolucci 29 Sep 2021, 11:21

Did it

Stefano Paolucci 29 Sep 2021, 12:19

Title disappeared, both description aren't visible, name of product page isn't the metatitle I set.

I've just resolved these problems in desktop. If you can, resolve only problems on mobile.

Update:
Specific prices get cancelled after few seconds/minutes, are you are working on them?

Fred 30 Sep 2021, 17:47

There is a problem with the languages. As I can see you currently have two languages and first one (English is disabled.)
If you don't using it, could you please try to delete it at all?

Stefano Paolucci 30 Sep 2021, 18:40

Deleted it.

Does the English language also affect specific prices?

Fred 30 Sep 2021, 19:05

The issue is really strange. We see it first time.
Let me explain it a bit to you
When AMP module request a product name it get an array instead of just a name and that's really a problem, that looks like this

Array ( [2] => Borraccia pieghevole )

instead of this

Borraccia pieghevole

We also spent a lot of time on that with no success.
Do you have an option to reinstall your shop from scratch?

Stefano Paolucci 30 Sep 2021, 19:31

Oh I see, I'll try to resolve by own before reinstall it.

Can you also check the problem of specific prices?
Specific prices get cancelled after few seconds/minutes I inserted them.
On the prestashop forum told me that could be a javascript conflict of the theme or a module.
Removing modules didn't change anything.

Fred 01 Oct 2021, 10:45

where I can see the issue?
I can't find a page with prices at all

Stefano Paolucci 01 Oct 2021, 13:49

I activated a module to hide prices for unregistered users. Login with these credentials to see them.
email: test@test.com pwd: testtest00

Then try to add specific prices to a product and after few seconds it'll disappear.

Fred 01 Oct 2021, 21:38

Ok, I see prices now.
But I can't find a product with special price

Stefano Paolucci 02 Oct 2021, 13:44

Exactly, this is the problem.
Special prices do not remain on the site.
After setting them on a product they disappear after a few seconds or minutes

Fred 02 Oct 2021, 23:04

I just created a discount to display special price and it just works https://take.ms/GHn1l

Stefano Paolucci 03 Oct 2021, 10:26

Yes, you can create it, but it's gone now. Disappears after a while

Fred 03 Oct 2021, 12:55

But the theme doesn’t manage prices. You can switch to the Classic theme to verify that

Stefano Paolucci 03 Oct 2021, 14:55

So what could be?

Fred 03 Oct 2021, 23:14

Please remind what modules did you recently installed and try to disable theme for a test

Stefano Paolucci 04 Oct 2021, 08:40

Hi Fred, sorry for this whole time to resolve my problems. Previously I've contacted all programmers of modules I installed and every of them told me that wasn't their module but tonight I found that was a module that cancelled me all specific prices. So sorry and thanks for everything

Fred 04 Oct 2021, 11:10

Ok, great!