• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 14.10.21, 10:54
  • Opened by: Nancy Grammenou

Ticket #22432 - Multilingual Homepage and other pages

Hello,

1. I read that we cannot select language on saved templates, so we must use Content Anywhere instead.
We edit the home page via Content Anywhere (display home) but the language selector is not working. We cannot choose language and the content is not showing on the front (we inserted the classic homepage and we can see it in backoffice)

2. We want to use Creative elements to edit other pages too. Eg “Terms & Conditions”. When we click on edit we get an error message. See the attachment. We turned off maintenance but this did not resolve the problem.

Attachments:

Capture.JPG (16.4 KiB)

Comments

Fred 14 Oct 2021, 11:06

1. "we must use Content Anywhere instead." - that is not a bug or an issue. It just works in this way. You have to add your layout in the Content Anywhere into the same hook the your have selected in the Theme Settings → Home
2. The issue should be fixed now. Please try

Nancy Grammenou 15 Oct 2021, 08:57

Οκ, thank you.
Can you please tell me which files have you edited? (we want to know for future updates)

Fred 15 Oct 2021, 09:27

/themes/alysum/templates/layouts/layout-both-columns.tpl

Nancy Grammenou 15 Oct 2021, 12:53

Ok but I still don t see the homepage on the front.
I edited via Content anywhere but this is still empty (although I see it in admin).
Also there are some blocks that I cannot remove (see the screenshot)

Attachments:

Capture.JPG (59.1 KiB)
Fred 15 Oct 2021, 13:17

The issue has been fixed. Please test to confirm the change
Updated file is
/themes/alysum/templates/layouts/layout-both-columns.tpl

Nancy Grammenou 15 Oct 2021, 21:03

ok, now it is working! thank you very much for the quick support.

Fred 15 Oct 2021, 21:04

You are welcome!
We would be grateful for supporting our theme if you like it and our service. You could rate it here http://themeforest.net/downloads

Nancy Grammenou 15 Oct 2021, 21:53

We have a second installation (we bought another license) and we face the exact problem.
We replaced the tpl you mentioned but it only solved part of the problem.
We can select language from backoffice and edit the template but we don t see the template on the front.
Is there something else we must do?

Fred 16 Oct 2021, 09:53

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your new installation Back-office and FTP

Nancy Grammenou 16 Oct 2021, 10:29

Ok, I added the login details for new installation

Fred 16 Oct 2021, 10:58

Just wondering, why didn't you install the latest theme version?
Is it possible for you to reinstall all from scratch using the latest Prestashop 1.7.8 and theme v.7.2.0?

Nancy Grammenou 18 Oct 2021, 08:46

We have already installed many modules and we have made some settings too. We have a deadline with our costumer so this is not an option for us. We didn t use the latest Prestashop cause we have working offline for a period.

Nancy Grammenou 18 Oct 2021, 08:47

We can update the theme if it does not cause any problems.

Fred 18 Oct 2021, 10:24

I'll try to update myself now

Fred 18 Oct 2021, 10:28

The issue has been fixed without update. Please test to confirm the change

Nancy Grammenou 18 Oct 2021, 10:52

Yes, it s ok now. Thank you!

Fred 18 Oct 2021, 10:57

You are welcome!