• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 30.11.21, 20:37
  • Opened by: Alice Thevin
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #22700 - Creative elements - results not showing front-end

Hello guys,

We are working on the header and footer right now (hook on creative element builder displayHeaderBuilder and displayFooterBuilder, and working from content anywhere) and when we make some changes, it works in the creative element builder just fine, but not on the real website...

see the screenshot attached please :

On the point 1. we would like to have some visual effects in the header through the creative elements builder, it does work in the builder itself but not on the website after saving changes, why?

On the point 2., the brands are just not working in carousel as it is defined in the parameters, and that would be great if we could understand why ? We would like to have them in carousel with no stop between the images like in the website : https://www.wildsouls.gr/en

Thanks a lot in advance if you could explain also ! :-)

Chris & Alice

Attachments:

Comments

Alice Thevin 30 Nov 2021, 20:41

Also Fred, the social media icons in the footer disappear on the website... we use a creative elements effect, which we could not use, but is there a way to fix that bug too please?
Did we configurated the creative elements with the theme setting wrong??

Fred 01 Dec 2021, 17:53

Hi, Alice.
I can't really understand the problem.
I have compared your header in back office and front page and don;sst see the problem you described.
Ho to see the issue?
Other problems are solved

Alice Thevin 01 Dec 2021, 19:07

Hello,
You can see attached two screenshots, and you can see that we don't see on the website what we have on the creative elements builder
Is there a parameter to change in the theme in order to not override the design setting in creative elements?

Attachments:

WebsiteView.png (152.8 KiB)
Alice Thevin 01 Dec 2021, 19:09

Oh and also, please can you tell me what is happening here?

It seems that when we edit with creative elements, we can see something related to the blog under the footer section, but not in the definitive website.
Is there the module attached to a hook that makes this appear? I checked displayHeaderBuilder and I unhooked the blog module from it, but still showing...

Thanks in advance Fred!!

Attachments:

Fred 01 Dec 2021, 19:18

1. I really don't see any difference. If you mean the height if blocks are different, that's because control elements requires more space. That is not a bug or an issue.
2. You see there blog and other modules, because they are hooked in the same hook as Creative Elements. You can go to Design → Positions and unhook those modules or just ignore that, that is not a problem at all

Alice Thevin 01 Dec 2021, 19:38

But the header is totally different on both screenshot, isn't it? The effect seperation form on bottom is Mountain, for the example, and we can't see it on the final website

Alright, I tried to unhook on the displayHeaderBuilder but it does not change anything, I'll try to find a solution then..

Fred 01 Dec 2021, 20:46

I can't find where did you add that background image. Please show it to me at a screenshot

Alice Thevin 02 Dec 2021, 18:58

It is in the section setting, style, then color in blue and effect of separation form
In order to have the full header background modified, we need to modify the section style

Attachments:

Fred 03 Dec 2021, 12:13

The issue has been fixed. Please test to confirm the change https://take.ms/7LEfC

Alice Thevin 03 Dec 2021, 16:44

It is in the section setting, style, then color in blue and effect of separation form
In order to have the full header background modified, we need to modify the section style

Attachments:

Fred 03 Dec 2021, 17:12

Yes, I already know. The issue is fixed, isn't it?

Alice Thevin 04 Dec 2021, 15:35

Yes thanks for the header it is fixed now !!

About the section under the footer appearing when we edit using creative elements, we know it is not an issue but we like when everything is properly done, we tried to find the hook and deactive it in order to delete these useless sections but we can't manage to do it, could you please tell us how to do so?

Thanks Fred and good day to you,

Fred 05 Dec 2021, 21:53

The issue has been fixed. Please test to confirm the change

Alice Thevin 07 Dec 2021, 22:06

Unfortnatelly we still see some stuffs under the footer section when we edit the homepage, or header, or footer only

We also looked the hook and can't find the relation to disconnect the modules doing this bug

Fred 07 Dec 2021, 22:58

I don't see that. Please check out my screenshot https://take.ms/E3wC6

Alice Thevin 07 Dec 2021, 23:37

Oh well it seems to be fixed now, I have to clean the cache from google chrome regularly if I want to see the changes applied correctly !

Thanks a lot Fred :))

Fred 07 Dec 2021, 23:54

You are welcome!