• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 13.12.21, 18:17
  • Opened by: pete ragaisis
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #22775 - amp general setting for telegram url

Hi,
on amp version homepage when I click on telegram icon it opens url: “telegram.org” but not the required group url from settings. i think the same is with facebook and maybe whatsup...

Comments

Fred 13 Dec 2021, 19:11

Where I can see Telegram icon? I can't find it

pete ragaisis 13 Dec 2021, 19:18

it was there on /mobile version at the bottom left corner jus few minutes ago,
and it disapeared because of the time setting: "Messengers availability until"

now it is there again, please chek again

Attachments:

pete ragaisis 13 Dec 2021, 19:54

and also i cant find same option (telegram group url) for general desktop version. there is only facebook and whatsap available as chat icons. but it's not reasonable to have different chat icons on mobile-amp and desktop versions...

Fred 14 Dec 2021, 10:39

1. It's fixed.
2. yes, there is no Telegram option for desktop.
To add you you just need to add following codes:

<a rel="nofollow noreferrer" href="URL" class="amp-pktelegram flex-container align-items-center justify-center" target="_blank" title="Telegram">
  <svg class="svgic"><use xlink:href="#si-telegram"></use></svg>
</a>

and CSS

.amp-pktelegram {
  background: #fff;
  border-radius: 50%;
  width:56px;
  height: 56px;
  box-shadow: 3px 3px 7px 0px rgba(0,0,0,0.2);
  margin-bottom: 10px
}
.amp-pktelegram svg {
  width:60%;
  height: 60%
}
pete ragaisis 14 Dec 2021, 14:52

added html to layout-both-columns.tpl but maybe through creative elements would be better in terms of template updates
anyway thanks for solution...

Fred 14 Dec 2021, 16:10

no, that's a good file. You are welcome