• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 10.05.22, 16:57
  • Opened by: Elie Naulleau
  • Closed by: Fred
  • Closed on: 23.05.22, 11:56
  • Reason: Closed
  • Comment: Glad to help!

Ticket #23338 - Search bugs at first time, second time works

Hello there,
This is a small problem but it is quite annoying for customers.
When using the search field with product autocompletion , the first attempt fails : no product is shown. However trying again solves the issue. (example of search : ‘abc’ or ‘kit’ or ‘poupe’ ). Ulterior searches works. This is only the very first one that fails.
(Notice that there is another search field at the bottom of the page but this one has no autocompletion. If I remove it from the footer template, it does not solve the problem of the top search field, I tried that at first assuming there was some kind of conflit. It does not seem the case).

Thank you for you help

Comments

Fred 11 May 2022, 10:03

Hi, Elie Naulleau.
Please try following CSS fix (Theme Settings → Customer CSS)

body .pk_search_result {
  left:0 !important;
}
Elie Naulleau 14 May 2022, 15:34

Hi Fred,
Thanks. I put the css in the Custom CSS field, emptied Prestashop cache and browser cache then tested it, the issue is still here.
For instance search for 'abc' (no result) then search for 'kit' (some results) then search for 'abc' (some results).
Elie

Fred 15 May 2022, 23:05

It works correctly for me from the first attempt to search - https://take.ms/EymST9 Maybe that's a cache of your browser, try in Incognito mode

Elie Naulleau 16 May 2022, 09:39

I tried in Incognito/private mode with the following browsers (on Mac OS X): Chrome, Brave, Firefox, and Safari. All browsers being in their last version.
For me the search still always fails he first time :(

Fred 17 May 2022, 10:03

I have checked out every browser I have and didn't see that problem. I have recorder a video for you https://take.ms/Puvsi

Elie Naulleau 21 May 2022, 11:15

Yes indeed I can see on your video it appears to work. That is a mysterious glitch. At some point I thought it could be related to the selected language, but this is not the case. I eventually was able to test it under Windows 10 (Chrome) and it works perfectly ! Strangely enough, it does not work (for me and some relatives) on Mac OS X, Windows seems fine.

Fred 21 May 2022, 15:13

The video I sent you is taken on Mac OS. Have you tried to check it out on another computer?

Elie Naulleau 21 May 2022, 19:44

Well, it turns out that the first search attempt :
- works well on Windows
- works well on Mac OS X Catalina (Intel) on : Safari; Chrome, but does not work on Firefox
- does not work on Mac M1 (arm) Mac OS X Monterey : wither neither Chrome, Brave, Firefox, Safari

(All browsers being updated to their latest version).

I thing you may close the ticket, the issue does not seems due the Alysum theme ...

Thank you

Fred 23 May 2022, 11:56

ok, no problem