• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 01.06.22, 08:26
  • Opened by: Martina Farela

Ticket #23393 - Problem in cart in mobile version

Hello, I have 2 problems with the cart:

1.When I add products to the cart, they are not added until I refresh the page

2.When I want to delete products from the cart, they are not deleted until I refresh the page

attached videos

1. https://mega.nz/file/sGMiSKJa#pJTQgbl9c8S-u7vjWedWY34T0eXT_2IB2sBHzXfWrCM

2. https://mega.nz/file/MbdhUbKL#dww2afgcw4mom6xq1wf37eJXsmiQUShrXnGndC3SYdc

Comments

Fred 01 Jun 2022, 10:33

As I can see you are using Creative Element cart widget.
We recommend to use our widgets - https://take.ms/nPlAz

Martina Farela 01 Jun 2022, 10:39

but in the pc version it works. And the cart of the mobile version is the promokit header items.

Martina Farela 01 Jun 2022, 10:40

You can see the videos, right?

Fred 01 Jun 2022, 11:53

Yes, I see the issue.
There is some different problem now in file catalog/_partials/product-add-to-cart.tpl. Did you modify it?
Also some problems are generated by livechatpro module https://take.ms/4wHmK

Martina Farela 01 Jun 2022, 12:02

No, I didn't change anything in the .tpl
Yes, that's right, I saw the module error when we were in debug mode. But on PC there is also the module and it loads the cart correctly

Fred 01 Jun 2022, 12:14

Another two errors I see caused by following modules

correosexpress
advanceddateofdelivery

Could you please disable those modules for a while?

Martina Farela 01 Jun 2022, 12:18

Ok, they are already disabled

Fred 01 Jun 2022, 12:35

Ok, now it should work.
The main module Shopping Cart was not hooked into Header hook

Martina Farela 01 Jun 2022, 12:44

Yes, now it adds it correctly. But now when I add products it behaves weird. attached video

https://mega.nz/file/hS12FIQA#lFAR2Q7H4DN4CIsT_aiTCH0f7slw1dNOzpi5dl2xofw

Fred 01 Jun 2022, 20:21

Looks like a module conflict. Need more time to find out what's wrong

Martina Farela 02 Jun 2022, 16:35

Maybe it's the module "drive, click & collect (prestatilldrive)"
Thank you, I await your response.
All the best

Martina Farela 03 Jun 2022, 09:25

I disabled it and it keeps happening, so it must be from another module

Fred 03 Jun 2022, 11:20

Please try now, it should be ok. That was Creative Elements module

Martina Farela 07 Jun 2022, 08:25

Yes, it´s fixed.
Thanls Fred

Fred 07 Jun 2022, 10:09

You are welcome!