• Priority: Medium
  • Status: Assigned
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 05.08.22, 16:13
  • Opened by: Alvaro

Ticket #23644 - Error when editing product with Elementor

Hello Fred,

i have a very big problem...i cannot edit the product page with Elementor...every time i try to edit the product page using Elementor it gives me this error: (see attached image).

It does not happen in CMS pages, or in Templates etc.only in product page. Can you fix this for us please? The client wants to publish the new site and we need to solve this.

thanks

alvaro

Attachments:

Captura.JPG (24.6 KiB)

Comments

Fred 06 Aug 2022, 10:35

Hi, Alvaro.
Product page editor works for me - https://take.ms/uhHjh

Alvaro 08 Aug 2022, 10:45

hi Fred. thanks for your quick answer...i am afraid you tested on saturday at the same time i was doing a very old restoration of the site. But if you try now you will see that the page editor is not working at the product page. It works for the rest of the elements but not for the product page. It gives a hook error but i am not sure. I think that it will be easy for you to find the problem. Can you help me with this, please (as you have been doing all the time) ;)

thanks

alvaro

Fred 08 Aug 2022, 18:21

Looks like one widget is broken. Try to remove widgets one by one to find out which one is broken

Alvaro 09 Aug 2022, 15:36

Hello Fred...i am sorry but i'm lost...what do you mean by widget? How can i find these widgets and remove them? Do you mean a template in elementor or some item of elementor? Can you give me an example where i can find these widgets in order to remove them?

thanks

alvaro

Fred 09 Aug 2022, 15:38

I mean this pieces of layout (widgets) - https://take.ms/6oGgX

Alvaro 09 Aug 2022, 16:05

OK i see...but how can i remove them if i cannot even load Elementor for the product page? if you can guide me...i can try to do it. thanks!!!

Alvaro 09 Aug 2022, 16:30

Because every time i try to edit the product page with Elementor it gives me this error and i cannot do anything else...what can i do, Fred? see image..

Attachments:

Captura.JPG (40.7 KiB)
Fred 10 Aug 2022, 10:22

Maybe we are doing some different things, because for me Editor is working. Could you please show on a screenshot where you click to get that error?

Alvaro 11 Aug 2022, 15:38

Hello Fred,

i explain to you what i did. I designed a template for the product page using "saved tempaltes" and it was selected trough Theme options as the main product page...i tried yesterdsy to change this template for the Product page default template and everything was working again. Does ir make sanse to you? (in any casa, now it works..i lost some design items that i had on the othe templete but better than not being able to work with Elementor for the product page..)