• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 14.10.22, 09:32
  • Opened by: Vidmantas Dapkus
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #23840 - AMP issues detected in people-fashion.dk

From Google Search Console I get such kind of errors|:

Top critical issues*

Missing URL in HTML tag link rel=canonical.

Comments

Fred 14 Oct 2022, 16:59

That’s because Creative Elements overrides AMp. Go to Modules Manager and disable Creative Elements for mobile - https://take.ms/nYmy7

Vidmantas Dapkus 17 Oct 2022, 21:02

I disable Creative Elements for mobile but still have validation issues regarding “!important” usage in AMP.

Fred 17 Oct 2022, 21:10

AMP is valid by default. Please make sure your custom CSS code doesn’t contain “!important”

Vidmantas Dapkus 18 Oct 2022, 08:31

Yes, the custom.css file has important. Is possible to load the different custom.css file for AMP only?

Fred 18 Oct 2022, 17:13

AMP does not use the same CSS files as desktop theme. It has it’s own custom CSS in the AMP Settings → Customer CSS