• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 22.10.22, 23:34
  • Opened by: Carlos Salazar
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #23867 - Cannot find menu theme options in backoffice

I just installed the theme on my multistore setup, but I cannot find the layout builder and other options that I can see in some of the tutorials. I attach an image of my actual promokit menu.

I want to know also how can I use the saved templates inside the Creative Elements menu to combine some of them in my shop.

Thanks in advance and kind regards,
Carlos.

Comments

Fred 23 Oct 2022, 10:33

Hi, Carlos.
Look like something was not installed properly.
Try to reinstall Menu module
Of course you can assign to menu item layouts created in Creative Elements

Carlos Salazar 23 Oct 2022, 10:43

Thanks, but how can I reinstall one specific module?

Regarding the other question, “how can I use the saved templates inside the Creative Elements menu to combine some of them in my shop?”… I am talking about the templates shown in the attached image under “Plantillas guardadas”

Regards,
Carlos.

Attachments:

Fred 23 Oct 2022, 10:48

1. Go to Modules → Module Manager, find there menu and click Reset
2. Yes, you can assign those templates to menu items

Carlos Salazar 23 Oct 2022, 11:23

Hi Fred,

I just reset the menu module but the only change is the order in the left menu, please see attached image.

Regarding the second question, maybe it seems easy but it’s just a few hours since I met the 1.7 PS version… Let’s say I want to use the dailydeal-header (#17) from my saved templates for my website, how do I insert that template code into my pages?

Thanks again,
Carlos.

Attachments:

Fred 23 Oct 2022, 12:42

1. It’s not clear for me, Does the menu works for you now?
2. Go to Theme Settings → Header and select a template from the list
You can also find a lot of information here https://alysum5.promokit.eu/promokit/documentation/

Carlos Salazar 23 Oct 2022, 13:29

Hi Fred,

Regarding question #1, no I just see those three options that you saw in the attachment. I cannot access to the “xxx builder” options that I have seen in some video tutorials. I attach an image of one of those tutorials.

And OK, I solved #2 with you help! thanks!

Cheers,
Carlos.

Attachments:

Fred 23 Oct 2022, 15:10

Maybe you watched outdated video, Page builder now calls Creative Elements

Carlos Salazar 23 Oct 2022, 19:35

Hi Fred,

It seems I can use every template except both from daily deal in categories and product pages.

I would like to use these both but I just get the attached results:
https://alysum5.promokit.eu/dailydeal/en/13-coats https://alysum5.promokit.eu/dailydeal/en/tops/1-1-faded-short-sleeves-tshirt-2835934862834.html#/1-size-s/13-color-orange

Fred 23 Oct 2022, 22:24

Sorry, but it’s not clear for me where exactly the problem is.
Please give me more details where do you want to assign a template and what template

Carlos Salazar 25 Oct 2022, 19:05

Ok, let me start from scratch or, if you need it, I can open a brand new ticket, just let me know if I should do it.

I am having several issues issues on my PS 1.7.8.7 with a multishop set up (2 shops), where I have New York Theme already working for one shop and I am trying to set up Alysum Theme for the other one, but the theme is not working. These are some of the issues, there are much more:

1 - In the Promokit menu on the left hand side of the backoffice, I just see three options: Theme Settings, Google AMP and Menu
   a) How can I use the layout builder for pages or blocks? I saw in your documentation videos that there should be more menu options on the left hand side under Layout Builder hence I could manage a different layout for the product pages, but I cannot find that now
2 - When I activate any preset in the Theme Settings configuration, it just changes the home page and some little parts of the category or product pages. I want to use the "DailyDeal" preset but there is no way to have that same layout for the category or product pages. I am looking for these specific results:
   a) https://alysum5.promokit.eu/dailydeal/en/13-coats, for example in my page I see the categories tree on the left side and the page seems to be the one for the OldStyle preset, not this one from DailyDeal.
   b) https://alysum5.promokit.eu/dailydeal/en/tops/1-1-faded-short-sleeves-tshirt-2835934862834.html#/1-size-s/13-color-orange


Fred 25 Oct 2022, 21:18

Please fill out all necessary fields in your profile https://support.promokit.eu/index.php?do=myprofile to access to your Back-office and FTP Server

Carlos Salazar 26 Oct 2022, 10:38

Hi Fred,

Now you have the details in my profile.

Regards,
Carlos.

Fred 26 Oct 2022, 12:23

1. Here is NEW page builder https://take.ms/3fJGE

2. yes, there was missed category page template, I just added it here https://take.ms/xOP7o

Carlos Salazar 26 Oct 2022, 13:01

Thanks Fred, now category page is working.

Could you please let me know how did you activate it? So that I could solve it if any other template is missing.

I will keep building the site, hope this were the last questions for you!

Regards,
Carlos.

Fred 26 Oct 2022, 16:42

There was missed layout. I have imported it to your shop

Carlos Salazar 06 Nov 2022, 23:24

Hi Fred,

I have been trying to set up some more features, but for any reason it seems I may have deleted the template dailydeal category page so can you tell me how can I import it again?

I am sending you some more questions of the actual set up:
1- How can I put a hamburguer menu in the desktop home page? I have tried to set it up but I am not seeing that option for the Menu widget. See attached image: “1-Header-menu.png” 2- How can I set up the product page? I don’t want the brand to appear (it is above the title product). I also want to remove the brand, product reference and items in stock from the feactures section. See attached image: “2-product-page.png” 3- The buying-page has no margins, it puts the gift wrapping twice and shows a final confirmation of the order with a green alert and a font-type in the bottom text that has no connection with anything. See attached images “3-buying-page”, “4-shipping-method” and “5-order-confirmed” How can I change those settings?

Thanks,
Carlos.

Attachments:

Carlos Salazar 06 Nov 2022, 23:44

I have to split the upload of images…

Carlos Salazar 06 Nov 2022, 23:46

Images 1, 3, 4 and 5.

Attachments:

Images1.zip (1.9 MiB)
Carlos Salazar 06 Nov 2022, 23:47

Images 2

Attachments:

Fred 07 Nov 2022, 21:46

0. You can find all templates in the folder /modules/pkelements/src/Install/templates and import deleted DailyDeal template
1. There is no way to enable it. It appears automatically on small screens
2. There is no such option to switch those details off. You can hide it using CSS like this

.element-to-hide {
  display:none
}

We recommend to use Developer Tools of your browser to find selectors of details to hide https://www.youtube.com/watch?v=wcFnnxfA70g

3. Try following CSS fix

#wrapper, #wrapper .container, #content {min-width:auto;margin:0 auto}
Carlos Salazar 07 Nov 2022, 22:11

Thanks for the answer Fred.

0. I went through ftp to that folder but there is no dailydeal-category.json inside. I just see these files: dailydeal-footer.json, dailydeal-header.json and dailydeal-home.json
2. and 3. Where can I find the css file to update it?

Thanks,
Carlos.

Fred 07 Nov 2022, 22:26

Ok, I have attached it
Go to your back office → Theme Settings → Customer CSS

Attachments:

Carlos Salazar 07 Nov 2022, 23:17

Ok, the margins are now applied to the buying page, thanks!

I also tried to add this statement to the back office → Theme Settings → Customer CSS .product-brand {

  display:none

}
.product-features {

  display:none

}

But it keeps showing the brand name at the top and the features (brand name, ref and items in stock) in the features tab

Is there something missing?

Regards,
Carlos.

Fred 07 Nov 2022, 23:31

Try this

.product-brand { 
    display:none !important
}
.product-features {
    display:none !important
}

Don’t forget about prestashop cache

Carlos Salazar 08 Nov 2022, 00:15

Thanks Fred, I think you can close this request.

I have now to learn how to do a hamburguer menu for desktop layout… and it should work responsive, so I have to study a little bit.

Any help, appreciated!

Regards,
Carlos.

Fred 08 Nov 2022, 17:48

1. Open the file

/modules/pk_menu/pk_menu.php

find the line

$jsFile = 'modules/'.$this->name.'/views/js/front'.(_PS_MODE_DEV_ ? '' : '.min').'.js';

replace with

$jsFile = 'modules/'.$this->name.'/views/js/front.js';

2. Open the file

/modules/pk_menu/views/js/front.js

find the line

var breakpoint = 1024,

and adjust it as you need
3. Open the file

/modules/pk_menu/views/css/front.css

adjust breakpoints accordingly to the changes in js file

Carlos Salazar 09 Nov 2022, 18:16

Great, I’ll probably wait for a second go-live to try it… black friday is coming and I need to finish this first one.

Fred 10 Nov 2022, 19:07

ok