• Priority: Medium
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 24.10.22, 00:50
  • Opened by: Thomas ullrich
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #23868 - Sold out label on AMP Version is not shown on Alysum 7.4.0

Hi Promokit Team,

hope you are fine and safe.

My customers are a bit annoyed as the sold out label is not shown on AMP pages - although activated in settings. Is this a bug?

See attached.

Alysum amp page… : Setting Display ‘out of stock’ label activated
category page.jpg: sold out label on blue shirt is not shown
product detail.jpg: sold out in prduct detail is shown

Please open https://musterheld.net/157-brandneu on a mobile advice to see yourself.

Comments

Fred 24 Oct 2022, 19:10

Thank you we are fine! Keep working on our victory!
The issue seems to be fixed - https://take.ms/l24xu the only thing is the translation should be changed

Thomas ullrich 24 Oct 2022, 19:20

Thank you, Fred. Works now.

Where can I change the translation? Or can you change it to ‘Ausverkauft’?

Will this correction remain if I upgrade to Alysum 7.5.0.?

Fred 25 Oct 2022, 09:20

Go to International → Translations, select theme and language and use search to find a wording to translate

Thomas ullrich 30 Oct 2022, 02:02

Hey Fred,

Sorry I have to come Back in this. I updated the theme to 8.0.0 and noe the Sold Out Label in AMP Version is again not displayed.

We have to make the same correction again.

Thank you

Fred 30 Oct 2022, 21:47

Do you have a backup?
You need to restore this file
/themes/alysum/templates/mobile/catalog/_partials/miniatures/product-miniature.tpl

Thomas ullrich 31 Oct 2022, 10:37

Yes, I backed it all up and I have restored the file. No changes.
Out of stock label is still not shown in the miniature listing in AMP version.

Thomas ullrich 31 Oct 2022, 10:56

I just thought it works - but this was the detailed page. In AMP product detail page the label is shown - in the miniature overview it still is not shown.

Fred 01 Nov 2022, 21:44

The issue has been fixed. Please test to confirm the change

Thomas ullrich 01 Nov 2022, 23:04

WORKS. Thank you. Which file do I have to save/restore when updating the theme in the future in order not to lose this hack? Or will future theme updates include this correction?

Fred 02 Nov 2022, 19:45

/themes/alysum/templates/mobile/catalog/_partials/miniatures/product-miniature.tpl