• Priority: Medium
  • Status: Waiting on customer
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 15.11.22, 18:34
  • Opened by: Thomas ullrich

Ticket #23943 - Creative elements editor does not load widgets grid

Hi Promokit Support Team,

I upgraded the Alysum theme to 8.0.0. and my Prestashop to 1.7.8.7. No errors so far, but today I found out, that the CE Editor seems to be outdated now. It is still version 2.5.8. (should be 2.5.11. now) and it does not work properly anymore. It opens and it is loading the page content - but it dos not finalise the widgets grid. The spinner spins forever. See attached.

As this is part of the Alysum theme - do you happen to have version 2.5.11. for me? Maybe that’s all we need to solve this matter.

Thanks for your support
Thomas

Comments

Fred 15 Nov 2022, 19:13

Hi, Thomas.
You need to downgrade module version to previous one 1.4.10, to unlock upgrade option.
- Open phpMyAdmin
- find the table “ps_modules” - change the version - like this https://take.ms/4vroQ Then let me know I’ll continue with the module update

Thomas ullrich 16 Nov 2022, 00:45

Done, Fred. See attached.

Attachments:

Fred 16 Nov 2022, 18:37

I have updated module files but I don’t have access to back office to upgrade the module.
Go to Modules Manager, find Creative Elements and click Upgrade

Thomas ullrich 17 Nov 2022, 09:47

Hi Fred,

sorry, your admin account was deactivated. I re-activated it, you have backend access now with usual credentials.
Some things have changed. I do not have Premium CreativeElements now, cannot edit contents. Creative Elements was in the Promokit section in my admin menu before, now it is filed uder ‘Optimization’. I guess this goes hand in hand - as it is not the premium version any more. I tried to upgrade as you described. It does not work. I ends in an error message ‘Could not perform upgrade’, see attachment 1.

A very strange thing happened as well: Header and Footer of our (frontend) content were always white letters on black background. The frontend has changed! They are inverted now - black on white background. What happened?

I mean - it is not a real problem, as the content is the same and the store works normal. I just looks really different.

Yours
Thomas

Attachments:

Thomas ullrich 17 Nov 2022, 10:05

See the difference before (old screenshot) - after (now). Theme builder is not available as CE License is invalid. See Screen 3.

Thomas ullrich 17 Nov 2022, 10:12

Ah, I just managed to change (invert) the header by opening it and click on ‘save’, will do the footer now and invert it and we are back to normal look.

Thomas ullrich 17 Nov 2022, 16:11

So for repeating this message above - this happens when you press ‘F5 refresh’ in this editor.

I updated CE to 2.5.11, but this did not help. Cannot edit the settings in theme builder section and the error of not loading the widget grid still persists.
I openende CE in debug mode and there is a quite interesting debug error message (see attached or below).

(1/1) FatalErrorException
Compile Error: Cannot declare class CE\WidgetProductImage, because the name is already in use

in product-image.php line 14

Attachments:

Fred 17 Nov 2022, 18:14

Sorry, I didn’t know you have CE Pro version.
I have updated Promokit Widgets that causes the error “Compile Error: Cannot declare class CE\WidgetProductImage…”

Thomas ullrich 17 Nov 2022, 21:56

No prob. But it does not work. Still does not load the wigdets grid (see attached spinner) and the dropdown list of templates is empty (see attached).

Fred 18 Nov 2022, 15:42

The issue has been fixed. Please test to confirm the change

Thomas ullrich 22 Nov 2022, 13:00

That works, thank you. But the ‘price’ was really high. CE is working and loading the grid, but I cannot define, which template should be used for home, footer, header and so on. I guess this would be done in creative elements/theme builder section, but the list of templates is not shown there.

After a strange amount of hours of not getting in any orders, I checked the frontpages and found out, that the frontpage did not show the product grid. The categories were empty, jus showing header and footer. So I reinstalled the category page, which was erased for whateaver reason. I received an order shortly later and was sure everything was fine. Yesterday I found out, thet the product detail page was erased, too. It was just showing header and footer, I had to build it from scratch with CE. I couldn’t switch to another template in creative elements/theme builder section this is impossible (not showing any templates to select from). I found out the orders I received were purely from AMP pages, which were still working fine. I lost at least about 1000 Euros of orders on the weekend.
Meanhwile category and product pages are back but I still hardly receive any orders. It seems there are many bugs as the page is very very slow. Homepage started in 1,3 seconds before, now it needs more than 15 seconds and many requests are timed out. See attached. Something went wrong and I can’t say what. There are still no orders coming in. I will do a testorder now to see why.

Fred 22 Nov 2022, 17:25

- elements/theme builder - is not supporting by our theme. We have our own tool Theme Settings where you can assign CE layouts
- we never faced such issue before when some template was erased with no reason. I can report that to CE developers.
- that’s sad some issue leads to lose money and we are ready to investigate what’s happened, but as I wrote you are only one who report that.
- Our demo pages doesn’t use any extra cache, only settings in prestashop back office, and as you can see for example here https://alysum5.promokit.eu/en/tops/18-127-printed-chiffon-dress-2835934862850.html#/1-size-s/16-color-yellow it loads pretty fast

Thomas ullrich 23 Nov 2022, 11:20

We have our own tool Theme Settings where you can assign CE layouts —- There are no theme settings in my menu. See attached.(Oh, there is no option to attach anything here.)

Fred 23 Nov 2022, 16:54

Go to Modules, search “Theme Settings” and click “configure”

Thomas ullrich 23 Nov 2022, 17:09

Works. Thank you.

Fred 23 Nov 2022, 17:25

You are welcome!