• Priority: 0
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 09.10.23, 09:59
  • Opened by: Matthieu
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #24972 - Error

Hello,

Can you solve these errors on the console please

lockdown-run.js:17 Lockdown failed: TypeError: At intrinsics.Object.groupBy expected boolean not function

at isAllowedPropertyValue (lockdown-install.js:1:53384)
at isAllowedProperty (lockdown-install.js:1:53807)
at visitProperties (lockdown-install.js:1:55095)
at isAllowedPropertyValue (lockdown-install.js:1:53041)
at isAllowedProperty (lockdown-install.js:1:53807)
at visitProperties (lockdown-install.js:1:55095)
at lockdown-install.js:1:55523
at repairIntrinsics (lockdown-install.js:1:144597)
at lockdown-install.js:1:145462
at lockdown-run.js:4:3

(anonyme) @ lockdown-run.js:17
Afficher 1 autre frame
Afficher moins
lockdown-more.js:99 Protecting intrinsics failed: ReferenceError: harden is not defined

at lockdown-more.js:69:13
at Set.forEach (<anonymous>)
at protectIntrinsics (lockdown-more.js:44:22)
at lockdown-more.js:97:5

Comments

Fred 09 Oct 2023, 10:01

Where I can see those errors?
I assume that’s coming from some third party module

Matthieu 09 Oct 2023, 10:18

you can check on the homepage. If the error are coming from other module please tell me with module.

Attachments:

Sans titre.png (733.5 KiB)
Fred 09 Oct 2023, 11:16

as I assumed, the issue is coming from lockdown-install.js which neither a part of prestashop nor our theme/modules, so you have installed something that has that script .

Matthieu 09 Oct 2023, 11:57

it is possible to know witch module cause the problem?

Matthieu 09 Oct 2023, 15:46

lockdown-install.js was an extension for chrome.

can you check all these errors ?

Uncaught TypeError: Cannot read properties of undefined (reading ‘debug’)

  at bottom-30a52a315.js:37:93033
  at bottom-30a52a315.js:311:190
  at bottom-30a52a315.js:311:194

masonry.js:3 Uncaught ReferenceError: $ is not defined

  at masonry.js:3:1

cookies.js:4 Uncaught ReferenceError: jQuery is not defined

  at cookies.js:4:184
  at cookies.js:4:192

alysum.js:1 Uncaught ReferenceError: pktheme is not defined

  at alysum.js:1:23

product.js:7 Uncaught ReferenceError: jQuery is not defined

  at product.js:7:1407

jquery.zoom.min.js:6 Uncaught TypeError: Cannot set properties of undefined (setting ‘zoom’)

  at jquery.zoom.min.js:6:129
  at jquery.zoom.min.js:6:2535

scripts.js:157 Uncaught ReferenceError: jQuery is not defined

  at scripts.js:157:4

front.js:20 Uncaught ReferenceError: $ is not defined

  at front.js:20:1

scripts.js:1 Uncaught ReferenceError: $ is not defined

  at scripts.js:1:1

scripts.js:11 Uncaught ReferenceError: $ is not defined

  at scripts.js:11:1

scripts.js:10 Promokit Favorites module is not installed properly. Try to reset it.
Favorites @ scripts.js:10
slick.js:25 Uncaught ReferenceError: jQuery is not defined

  at slick.js:25:11
  at slick.js:28:2

scripts.js:3 Uncaught ReferenceError: $ is not defined

  at scripts.js:3:1

front.js:3 Uncaught ReferenceError: jQuery is not defined

  at front.js:3:19
  at front.js:3:1708

coffret-allaitement-naturel-coquillages-cicatrisants-coussins-confort-ebook-offert#/1-taille-s:1 The resource https://geniuz.fr/modules/creativeelements/views/lib/ceicons/fonts/ceicons.woff2?fj664s was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally.
coffret-allaitement-naturel-coquillages-cicatrisants-coussins-confort-ebook-offert#/1-taille-s:1 [Deprecation] The keyword ‘inner-spin-button’ specified to an ‘appearance’ property is not standardized. It will be removed in the future.
coffret-allaitement-naturel-coquillages-cicatrisants-coussins-confort-ebook-offert#/1-taille-s:1 [Deprecation] The keyword ‘inner-spin-button’ specified to an ‘appearance’ property is not standardized. It will be removed in the future.
coffret-allaitement-naturel-coquillages-cicatrisants-coussins-confort-ebook-offert#/1-taille-s:1 The resource https://geniuz.fr/modules/creativeelements/views/lib/ceicons/fonts/ceicons.woff2?fj664s was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally.

Matthieu 09 Oct 2023, 16:23

you can check this error on product page like this :https://geniuz.fr/coupe-frite/geedel-coupe-frites

Fred 10 Oct 2023, 12:45

Ok, I see now.
We never had such issue with the theme, so I believe that’s a question of configuration.
As I can see, some essential scripts are not loading on product page. I assume some module doing that, probably Creative Elements.
Could you please switch to Classic prestashop theme and check how it works there. Please make sure Creative Elements is enabled after switching to Classic theme.

Matthieu 10 Oct 2023, 13:18

only 1 error when I swtich on Classic prestashop them.

popup.js:8 Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘query’)

  at getCurrentTabId (popup.js:8:32)
  at popup.js:29:1
Fred 10 Oct 2023, 13:25

and CE is enabled?

Matthieu 10 Oct 2023, 13:31

yes . but when it is active there is problem with jquery I think. You can check it now

Fred 10 Oct 2023, 15:14

Yes, I see. Ok, I just switched back to Alysum theme to continue to work with the issue…

Matthieu 10 Oct 2023, 16:08

Ok. Can you check .htaccess if there is no problem with this file ?

Fred 11 Oct 2023, 11:39

that file is generated automatically, I never experienced any problems with that

Matthieu 11 Oct 2023, 11:41

Ok. Have you identify where the problem come from ?

Fred 11 Oct 2023, 11:48

Not yet

Fred 12 Oct 2023, 10:13

The issue has been fixed. Please test to confirm the change
Updated file is /themes/alysum/templates/catalog/product.tpl

Matthieu 12 Oct 2023, 10:34

Hello Fred,

Normally the button for this product should be buy on amazon ( it is written with add to cart )

https://geniuz.fr/casque-anti-bruit-bebe/bbtkcare-casque-anti-brui There is still problem with jquery.

Also category product is not display good

https://geniuz.fr/casque-anti-bruit-bebe

Matthieu 12 Oct 2023, 10:41

also problem on mobile

Fred 12 Oct 2023, 15:24

1. Where is that Amazon button? I can’t find it
2. I see some custom code on category product “material-icons search…” I believe that’s a reason of the issue. Try to restore default page view.

Matthieu 12 Oct 2023, 15:42

1. It is a module for amazon. It is working when I switch on classic theme but not with your theme. You can try it.
2. I have not put custom code . It is coming from creative element ?

Fred 13 Oct 2023, 15:03

1. Please try to reset that module, it helps in 99%
2. I have no idea how it’s configured. Try to start with default configuration and add your changes to see what brakes the layout

Matthieu 13 Oct 2023, 15:06

any news ?

Fred 13 Oct 2023, 15:10

1. Please try to reset that module, it helps in 99%
2. I have no idea how it’s configured. Try to start with default configuration and add your changes to see what brakes the layout

Matthieu 13 Oct 2023, 15:21

I have disable the 3 moduules that I have add and it is not working. I have also try to reset creative element… mobile version and category page have stop working after your Updated file this /themes/alysum/templates/catalog/product.tpl

Fred 13 Oct 2023, 16:17

Yes, sorry, my bad. Now it should be ok

Matthieu 15 Oct 2023, 14:59

Now it is working.

I have new errors.

Description
Pages with the <title> element outside the <head> element in the HTML. The <title> of the page must be in the <head> element; otherwise, it risks being ignored by search engines. Google generally recognizes the page title even if it is located outside the <head> element, but this is not systematic.

How to fix
Make sure the <title> element is within the <head> element of a page’s HTML code so that browsers can use it at the top of the window and search engines can use it to the calculation of the score.

Can you check it ?

Fred 16 Oct 2023, 16:45

I’m sure that problem caused by third party broken code. Please disable your third party modules one by one and check that.
We never had this issue before

Matthieu 16 Oct 2023, 16:59

this problem is cause by another module

Fred 17 Oct 2023, 10:47

So we can close this ticket?

Matthieu 17 Oct 2023, 10:52

yes module amazon affiliate shop import

Fred 17 Oct 2023, 11:28

Ok, thanks