• Priority: 0
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 16.10.23, 15:38
  • Opened by: Matthieu
  • Closed by: Anonymous Submitter
  • Closed on:
  • Reason: Not a bug

Ticket #24985 - Can't edit category page

Hello,

Now I can’t edit category page.Creative element says me that it is come from your theme.

Regards,

Comments

Fred 18 Oct 2023, 23:17

Hi, Matthieu.
I have enabled Debug mode to be able to read error messages and found out following error:

Unable to load template 'file:_partials/fixed-content.tpl' in 'layouts/layout-both-columns.tpl'

CE is trying to load “fixed-content.tpl”. But neither our theme nor Classic doesn’t have such file.

Matthieu 19 Oct 2023, 08:45

OK I will contact support of creative element

Matthieu 19 Oct 2023, 09:07

have you touch something? Because this message was not appear yesterdays. All website have stop working.

Fred 19 Oct 2023, 09:56

No need to contact CE support. As I can see something wrong in general, I’ll try to figure out what’s exactly

Fred 19 Oct 2023, 09:59

Do you use some extra cache option?
As I can see that error appears on every page, but there is no any reference to _partials/fixed-content.tpl in the layouts/layout-both-columns.tpl

Matthieu 19 Oct 2023, 10:01

there is a speed module optimization but everything is disable and until now this module was working

Fred 19 Oct 2023, 10:31

Where this reference “_partials/fixed-content.tpl” could come from? we never had such file in the theme.

Matthieu 19 Oct 2023, 10:47

I don’t know it is not me . I will ask to the support of other module.

Fred 19 Oct 2023, 10:52

I’m afraid they will not help you, but you can at least ask

Matthieu 19 Oct 2023, 10:55

I can restore the website. Yesterday it was working

Fred 19 Oct 2023, 12:40

Ok, please try

Matthieu 19 Oct 2023, 13:45

it is repair

Fred 20 Oct 2023, 15:50

Try this trick, enable native category page layout https://take.ms/jeBeb then go to category page in back office to edit it with CE
Actually I just tried that, but it seems some cache enabled, because I still don’t see “Native layout” there

Matthieu 23 Oct 2023, 11:50

Category page display is not correponding to the category page configure. How I can have the good one ?

Attachments:

Matthieu 23 Oct 2023, 16:28

I think you have correct something because it is working but now I can’t edit the page.

Fred 24 Oct 2023, 15:23

I just clicked on category page template and edit mode works fine → https://take.ms/CKPCD

Matthieu 24 Oct 2023, 15:26

try to edit with creative element on this category. It is not working:

casque anti bruit bébé	

Attachments:

Fred 25 Oct 2023, 12:13

Try following workaround, go to Theme Settings → Category page and select native layout https://take.ms/2P1dB

Then go to category and try to edit it

Matthieu 25 Oct 2023, 17:18

I can modify like this but text is display two times. I don’t understand…

https://geniuz.fr/casque-anti-bruit-bebe

Fred 26 Oct 2023, 10:31

Could you please check why website is not loading for me? It stays like this all the time: https://take.ms/vTLi3

Matthieu 26 Oct 2023, 13:55

can you check it everything is working on my side.

Matthieu 26 Oct 2023, 16:37

you trick is not a solution because it is not practical when I want to modify category page and link are removed each time…

Fred 26 Oct 2023, 19:41

As I can see everything is working fine.
What link is removed? I don’t see

Matthieu 26 Oct 2023, 20:35

No text are duplicate. when I switch on creative elements all links disappears. Please fix this problem for a normal use.

Fred 27 Oct 2023, 08:48

But what links are disappear? Could you please show me on a screenshot?

Fred 28 Oct 2023, 10:42

Double description and link issues are fixed.
Now it also should work with selected template, not need to switch.
Please test and let me know

Matthieu 28 Oct 2023, 13:21

Now I can modify it thank you . But category page configure in theme setting is not display, also the home page.

Fred 28 Oct 2023, 17:59

Sorry my bad. I didn’t check the front page. Now it’s fixed

Matthieu 31 Oct 2023, 13:16

Thank you. The problem is come back… why ? how I can correct it ?

Fred 31 Oct 2023, 17:15

I didn't touch anything. What did you do with theme files recently?

Matthieu 31 Oct 2023, 19:58

I have just edit and save some page…

Fred 31 Oct 2023, 21:46

I don't know what's going on.
I just fixed it once more. Updated file is /themes/alysum/templates/_partials/helpers.tpl