• Priority: 0
  • Status: Closed
  • Theme: Alysum
  • Assigned To: Fred
  • Private: No
  • Open Date: 31.01.24, 18:01
  • Opened by: Catina Charter
  • Closed by: Fred
  • Closed on: 21.02.24, 19:36
  • Reason: Closed
  • Comment: Glad to help!

Ticket #25266 - Products appearing in a category it is not associated with

We have an issue with products appearing on the page that it is not associated with, please see the attached screenshots.

Comments

Fred 01 Feb 2024, 09:45

Hi, Catina.
Please give me a link the that category where that product should not appear

Catina Charter 01 Feb 2024, 15:26

Hi,

https://dev.finelacewigs.com/2-human-hair-wig

Only the products associated with this category should appear however all of the products in the entire store have been associated to this page.

Thank you

Fred 01 Feb 2024, 21:39

it's a bit hard for me to find out which product is not in that category, could you please give me more information?

Catina Charter 01 Feb 2024, 22:22

I will check them one by one and make a list.

Thank you

Fred 01 Feb 2024, 22:47

Yes, please

Catina Charter 02 Feb 2024, 03:03

Hi, Fred

I believe the issue is related to multiple products and categories, I encountered the same problem while associating categories on the faceted search. Can you please have a look at the screenshots attached?

I selected the categories I desired to show in the search but they do not show

I selected the option for the products in the subcategories not to show however none of the categories I chose to show on the search.

I did not select Shampoo and conditioner but all the products appear, please click the link below https://dev.finelacewigs.com/2-human-hair-wig

Fred 02 Feb 2024, 09:44

Faceted Search is a native Prestashop filter, not our module. And I assume it works in a bit different way than you expected. I'm sure if you will switch to Classic theme you will see the same categories in filter which you can see now in Alysum theme. Because the theme just display data received from backend

Catina Charter 02 Feb 2024, 18:45

Thank you.

I have switched the view to classic, I will test it now.

Fred 02 Feb 2024, 20:01

Let me know the result

Catina Charter 02 Feb 2024, 22:29

I placed it on classic view, I have tried several settings and the Medical wigs category does not appear

Click here https://dev.finelacewigs.com/

Click here https://dev.finelacewigs.com/1512-medical-wigs

Fred 02 Feb 2024, 22:46

Yes, that's what I wrote you about. That module just works in that way and that's not our theme's issue. I can't even say is that a bug or a feature, because that's not our module.

Catina Charter 02 Feb 2024, 22:53

If the filter needs to be set in a specific way to work with your theme please let us know. I am testing I will make any changes you advise us to apply, it is my understanding you built the theme to use the faucet feature for sorting, just need to know which presets you used for the demo.

Fred 02 Feb 2024, 23:07

When I wrote Classic theme I meant this https://take.ms/Teafn

Catina Charter 02 Feb 2024, 23:56

This feature is offered as a standard option on your theme I am seeking counsel because it is not working on your theme

Catina Charter 02 Feb 2024, 23:59

If you can tell me how you have it programmed on the demo I will use the same setting you used. Thank you

Fred 03 Feb 2024, 00:03

Maybe I misunderstood you, or missed something, could you please repeat what feature is offered as a standard option?

Catina Charter 03 Feb 2024, 01:10

I added the link below, the filter is used as a preset, Can you please show me a screenshot of how you programmed it?

Thank you

https://alysum.promokit.eu/dailydeal/en/3-women

Catina Charter 03 Feb 2024, 01:15

You fixed an issue with our product, after the issue was fixed we added a new category, medical wigs, for some reason it does not appear when we changed the theme

The entire category is missing although it appears on the home page, there appears to be something wrong with the links

Click here https://dev.finelacewigs.com/1512-medical-wigs

Attachments:

Catina Charter 03 Feb 2024, 03:22

When you modify the theme presets, all categories should be visible. However, after changing the presets on the saved theme, the categories some of the presets no no longer appear. I added a list in the prior email

Fred 03 Feb 2024, 09:44

1. I don't know who customised your theme before and why they did so. They hide some categories → https://take.ms/ilYQJ Go to Theme Settings → Customer CSS find that line and remove that code
2. In the filter settings please make sure you have selected all categories https://take.ms/lrMi1

All those issues are not related to the theme presets modification

Catina Charter 21 Feb 2024, 17:49

This is resolved. Please close the ticket