We offer professional Design/Code Customisation and Website Optimisation Service Request Customisation
  • Status: Waiting on customer

Ticket #11760 - Image on over not works

In category page not works over effect.
Images not change when mouse go over image of product!

This ticket does not depend on any other tickets.

Marek (marek) 28 Feb 2018, 23:08

Please restore the file /themes/alysum/product-list.tpl which was changed a couple day ago
That is not theme issue, it's your customisation

Diego (aircrescio) 01 Mar 2018, 12:40

Nobody make that changes in this week! can you help me to understand the problem?

Marek (marek) 01 Mar 2018, 12:49

But I see the file has been changed on February 22. Please restore the version what was before

Diego (aircrescio) 01 Mar 2018, 12:58

Is very strange and I need understand how change and what!!! I don’t make any changes!

Marek (marek) 01 Mar 2018, 12:59

I also didn't touch anything. Do you have a back to restore the file?

Marek (marek) 01 Mar 2018, 13:00

Diego (aircrescio) 04 Mar 2018, 12:10

i don't find any changes on my way. Can you check the hover problem?

Marek (marek) 04 Mar 2018, 12:50

Please restore the copy of the file what was before the changes (22.02.2018)

Diego (aircrescio) 04 Mar 2018, 13:57

I haven’t it! I don’t make that change.

Marek (marek) 05 Mar 2018, 15:01

Here is the reason of the issue. That is not our code, but yours. You asked me to fix you code, sorry, but I can't. I this case I can only advice you to remove that condition

Diego (aircrescio) 05 Mar 2018, 15:12

No! That condition there is present also before and that condition check only the category id for use different images size and proportion in relation of category Id. And when we add that code hover works right! Is different months that we add that condition. Check the code, hover effect not depend of that.

Marek (marek) 05 Mar 2018, 15:15

but it doesn't allow the script to add second image

Diego (aircrescio) 05 Mar 2018, 15:18

Why not? When I add that code works right! I’m sure! I checked it different times!!!

Marek (marek) 05 Mar 2018, 15:51

You have overcustomized code. It's really hard to understand what's wrong there. If you want I'll ask Alex to help you for some price

Diego (aircrescio) 05 Mar 2018, 15:53

Ok, I can accept it, but is not related to my code because I’m with my code over effect works right! But I need a solution

Diego (aircrescio) 06 Mar 2018, 12:05

You can see that is not my code customization problem you can see my code in action in "Donna"–>"Abbigliamento" category page:
https://shop.ilamalu.it/donna/abbigliamento Here all works right!
Why not in Donna Category?

Please help me to fix it.

Marek (marek) 06 Mar 2018, 12:14

Once again I wrote you the issue is because you have customised the theme. I just fixed it and I don't want to get beck to this ticket more, sorry, but you waste my time. You have to pay for such tickets but I don't ask you to do that in this ticket.

Diego (aircrescio) 06 Mar 2018, 12:37

ok, but if i have customize theme why in one category works and in another one no? and i don't want waste your time but i need support.

Marek (marek) 06 Mar 2018, 12:37

Because of your customisation

Marek (marek) 06 Mar 2018, 12:38

I can support only in case theme or module issues

Diego (aircrescio) 06 Mar 2018, 12:41

ok, but my customization works as you can see at that link

Diego (aircrescio) 06 Mar 2018, 16:17

And now you can see that second image works, but keep wrong dimension.
In standard category need keep home_default dimension.
In selected category (you find condition in "IF CATEGORY LAYOUT VERTICALE" code section) need keep and use verticalbig_default dimension.
Vertical layout works right (https://shop.ilamalu.it/donna/abbigliamento)
I need fix standard behavior (https://shop.ilamalu.it/donna/) that need to continue to use, also for hover images, home_default dimension.

Marek (marek) 06 Mar 2018, 23:59

Write you once again, the reason of the issue is the customisation. If you need a help it will be paid service

Diego (aircrescio) 07 Mar 2018, 15:18

Ok, I also think about pay for fix, but I don’t understand because my custkm category layout works right and standard behaviour no. I think is a javascript issue and I can’t fix it... i’m Not able to do that

Marek (marek) 07 Mar 2018, 15:59

It's because of those conditions, there is some logical mistake. Ask Alex to help you, if he have a time

Diego (aircrescio) 08 Mar 2018, 01:25

Yes please

Alex Support (Admin) 08 Mar 2018, 13:20

Hi. For me hover effect works. I didn't make any modifications https://shop.ilamalu.it/donna

Please check.

Diego (aircrescio) 08 Mar 2018, 13:43

Works but in DONNA category with wrong images... images in that category must be square and cover entire box of product.

Diego (aircrescio) 09 Mar 2018, 17:45

i need fix only dimension of standard category that must be home_default dimension and not verticalbig_default that must used only fo product that are in selected categories.

Marek (marek) 13 Mar 2018, 19:59

Alex will reply you asap

Alex Support (Admin) 13 Mar 2018, 23:15

Hi. Sorry for waiting. For some reason I didn't get the ticket notifications.

Done the fix. Please check. As I see now everything ok in both categories home_default and verticalbig_default

If everything ok please pay 10 euro to PayPal [email protected] with the comment "AlexPromokit"